<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"><head> <script type="text/javascript">var bloginfo = {
				'url': 'https://www.gossipcop.com',
				'template_directory': 'https://www.gossipcop.com/wp-content/themes/gossipcop'
			};</script> <script>var _lmiConfig = {"id":9026,"gbAdsEnabled":true,"prebid":true,"bidders":["appnexus","rubicon","openx","yieldmo","pubmatic","aol","sovrn","conversant","sharethrough"],"lazyload":true,"amazonTAM":true,"moveAdFromAboveNav":true,"mobileAnchorRefresh":true,"rightRailRefresh":true,"removeTaboola":true,"newAdTech":true,"k2.js":"https:\/\/www.gossipcop.com\/wp-content\/themes\/gossipcop\/js\/k2.js?v=202001221056"};
			var _gbLMI = _lmiConfig.id || 9000;
		    var _gbTestEnabled = _lmiConfig.gbAdsEnabled ? true : false;
			var _postID = 906572;
			try{
				if (_lmiConfig.isForced) {
					console.log('DEBUG: Forced lmi=' + _lmiConfig.forcedLMI);
				} else if (_lmiConfig.isForceAttempt) {
					console.warn('DEBUG: Forced lmi=' + _lmiConfig.forcedLMI + ' does not exist');
				}
			}catch(e){}</script>
<style type="text/css" id="aoatfcss" media="all">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</style><noscript id="aonoscrcss"></noscript><title>Wedding Rings, Natural Disasters, And Paul Walker&#039;s Legacy Of Charity</title><meta name="description" content="Paul Walker was known for his philanthropic efforts, but the size and scale of the actor&#039;s charity aren&#039;t as well-known as they should be." /><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Oswald%7COswald%7CLato%7CLato" /><link rel="canonical" href="https://www.gossipcop.com/paul-walker-legacy-charity-wedding-rings-natural-disasters/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Wedding Rings, Natural Disasters, And Paul Walker&#039;s Legacy Of Charity" /><meta property="og:description" content="Paul Walker was known for his philanthropic efforts, but the size and scale of the actor&#039;s charity aren&#039;t as well-known as they should be." /><meta property="og:url" content="https://www.gossipcop.com/paul-walker-legacy-charity-wedding-rings-natural-disasters/" /><meta property="og:site_name" content="Gossip Cop" /><meta property="article:publisher" content="https://www.facebook.com/GossipCop/" /><meta property="article:section" content="Uncategorized" /><meta property="article:published_time" content="2020-02-04T00:30:21+00:00" /><meta property="article:modified_time" content="2020-02-03T23:25:37+00:00" /><meta property="og:updated_time" content="2020-02-03T23:25:37+00:00" /><meta property="og:image" content="https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6.jpg" /><meta property="og:image:secure_url" content="https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6.jpg" /><meta property="og:image:width" content="615" /><meta property="og:image:height" content="410" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Paul Walker was known for his philanthropic efforts, but the size and scale of the actor&#039;s charity aren&#039;t as well-known as they should be." /><meta name="twitter:title" content="Wedding Rings, Natural Disasters, And Paul Walker&#039;s Legacy Of Charity" /><meta name="twitter:site" content="@GossipCop" /><meta name="twitter:image" content="https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6.jpg" /><meta name="twitter:creator" content="@GossipCop" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>/*<![CDATA[*/{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.gossipcop.com/#organization","name":"Gossip Cop","url":"https://www.gossipcop.com/","sameAs":["https://www.facebook.com/GossipCop/","https://www.instagram.com/gossipcop/","https://twitter.com/GossipCop"],"logo":{"@type":"ImageObject","@id":"https://www.gossipcop.com/#logo","url":"https://www.gossipcop.com/wp-content/uploads/2019/12/gossip_cop.png","width":446,"height":85,"caption":"Gossip Cop"},"image":{"@id":"https://www.gossipcop.com/#logo"}},{"@type":"WebSite","@id":"https://www.gossipcop.com/#website","url":"https://www.gossipcop.com/","name":"Gossip Cop","description":"Busting bad dish!","publisher":{"@id":"https://www.gossipcop.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.gossipcop.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.gossipcop.com/paul-walker-legacy-charity-wedding-rings-natural-disasters/#primaryimage","url":"https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6.jpg","width":615,"height":410,"caption":"close photo of Paul Walker's face at the Fast & Furious 6 premiere"},{"@type":"WebPage","@id":"https://www.gossipcop.com/paul-walker-legacy-charity-wedding-rings-natural-disasters/#webpage","url":"https://www.gossipcop.com/paul-walker-legacy-charity-wedding-rings-natural-disasters/","inLanguage":"en-US","name":"Wedding Rings, Natural Disasters, And Paul Walker&#039;s Legacy Of Charity","isPartOf":{"@id":"https://www.gossipcop.com/#website"},"primaryImageOfPage":{"@id":"https://www.gossipcop.com/paul-walker-legacy-charity-wedding-rings-natural-disasters/#primaryimage"},"datePublished":"2020-02-04T00:30:21+00:00","dateModified":"2020-02-03T23:25:37+00:00","description":"Paul Walker was known for his philanthropic efforts, but the size and scale of the actor's charity aren't as well-known as they should be."},{"@type":"Article","@id":"https://www.gossipcop.com/paul-walker-legacy-charity-wedding-rings-natural-disasters/#article","isPartOf":{"@id":"https://www.gossipcop.com/paul-walker-legacy-charity-wedding-rings-natural-disasters/#webpage"},"author":{"@id":"https://www.gossipcop.com/#/schema/person/30014352a73081cc9f57676921a3de66"},"headline":"From Wedding Rings To Natural Disasters: Paul Walker&#8217;s Legacy Of Charity","datePublished":"2020-02-04T00:30:21+00:00","dateModified":"2020-02-03T23:25:37+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.gossipcop.com/paul-walker-legacy-charity-wedding-rings-natural-disasters/#webpage"},"publisher":{"@id":"https://www.gossipcop.com/#organization"},"image":{"@id":"https://www.gossipcop.com/paul-walker-legacy-charity-wedding-rings-natural-disasters/#primaryimage"},"articleSection":""},{"@type":["Person"],"@id":"https://www.gossipcop.com/#/schema/person/30014352a73081cc9f57676921a3de66","name":"Elyse Johnson","image":{"@type":"ImageObject","@id":"https://www.gossipcop.com/#authorlogo","url":"https://secure.gravatar.com/avatar/d989e08e4e35934260564caa2e7b559f?s=96&d=mm&r=pg","caption":"Elyse Johnson"},"sameAs":[]}]}/*]]>*/</script> <link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Gossip Cop &raquo; From Wedding Rings To Natural Disasters: Paul Walker&#8217;s Legacy Of Charity Comments Feed" href="https://www.gossipcop.com/paul-walker-legacy-charity-wedding-rings-natural-disasters/feed/" /> <script type="text/javascript" data-cfasync="false">var mi_version         = '7.7.1';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-45900089-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-45900089-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
	__gaTracker('set', 'dimension1', String(window._gbLMI ? window._gbLMI : 9000));
if(window._postID){ __gaTracker('set', 'dimension3', String(window._postID)); }
		__gaTracker('set', 'anonymizeIp', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script> <noscript><link rel='stylesheet' id='wp-block-library-css'  href='https://www.gossipcop.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /></noscript><link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" id='wp-block-library-css' href='https://www.gossipcop.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /> <noscript><link rel='stylesheet' id='stt_related_styles-css'  href='https://www.gossipcop.com/wp-content/cache/autoptimize/css/autoptimize_single_d2b44139111f680f1c65e4d9768975ba.css' type='text/css' media='all' /></noscript><link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" id='stt_related_styles-css' href='https://www.gossipcop.com/wp-content/cache/autoptimize/css/autoptimize_single_d2b44139111f680f1c65e4d9768975ba.css' type='text/css' media='all' /> <script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"https:\/\/www.gossipcop.com","hash_tracking":"false"};</script> <link rel='https://api.w.org/' href='https://www.gossipcop.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.gossipcop.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.gossipcop.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 2020.06" /><link rel='shortlink' href='https://www.gossipcop.com/?p=906572' /><link rel="alternate" type="application/json+oembed" href="https://www.gossipcop.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.gossipcop.com%2Fpaul-walker-legacy-charity-wedding-rings-natural-disasters%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.gossipcop.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.gossipcop.com%2Fpaul-walker-legacy-charity-wedding-rings-natural-disasters%2F&#038;format=xml" /> <script type="application/ld+json">/*<![CDATA[*/{"@context":"http:\/\/schema.org","@type":["NewsArticle","ItemList"],"mainEntityOfPage":"https:\/\/www.gossipcop.com\/paul-walker-legacy-charity-wedding-rings-natural-disasters\/","publisher":{"@type":"Organization","name":"Gossip Cop","logo":{"@type":"ImageObject","url":"https:\/\/www.gossipcop.com\/wp-content\/uploads\/2017\/01\/gossipcop-amp-publisher-logo.jpg","height":60,"width":214}},"headline":"From Wedding Rings To Natural Disasters: Paul Walker&#8217;s Legacy Of Charity","description":"Paul Walker was more than an actor who charmed audiences with his personable smile and brilliant blue eyes. The actor was also known for his philanthropic efforts because he loved to help people. Walker was a generous giver, often known for giving to random strangers and fans. One story in particular is when Walker anonymously [&hellip;]","datePublished":"2020-02-03T19:30:21-05:00","dateModified":"2020-02-03T18:25:37-05:00","author":{"@type":"Person","name":"elyse-johnson"},"image":{"@type":"ImageObject","url":"https:\/\/www.gossipcop.com\/wp-content\/uploads\/2020\/02\/Paul-Walker-FF6.jpg","width":615,"height":410},"itemListElement":{"type":"ListItem","position":1,"item":{"@type":"ImageObject","image":"https:\/\/www.gossipcop.com\/wp-content\/uploads\/2020\/02\/Paul-Walker-FF6.jpg","name":"From Wedding Rings To Natural Disasters: Paul Walker&#8217;s Legacy Of Charity","url":"https:\/\/www.gossipcop.com\/paul-walker-legacy-charity-wedding-rings-natural-disasters\/#attachment_906623"}}}/*]]>*/</script> <link rel="apple-touch-icon" sizes="180x180" href="/wp-content/uploads/fbrfg/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/wp-content/uploads/fbrfg/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/wp-content/uploads/fbrfg/favicon-16x16.png"><link rel="manifest" href="/wp-content/uploads/fbrfg/site.webmanifest"><link rel="mask-icon" href="/wp-content/uploads/fbrfg/safari-pinned-tab.svg" color="#5bbad5"><link rel="shortcut icon" href="/wp-content/uploads/fbrfg/favicon.ico"><meta name="msapplication-TileColor" content="#da532c"><meta name="msapplication-config" content="/wp-content/uploads/fbrfg/browserconfig.xml"><meta name="theme-color" content="#ffffff"><link rel="amphtml" href="https://www.gossipcop.com/paul-walker-legacy-charity-wedding-rings-natural-disasters/amp/" /><link rel="preload" as="script" href="https://www.googletagservices.com/tag/js/gpt.js" /><link rel="preload" as="script" href="//d3hbiib542dh57.cloudfront.net/script.js" /> <script>//var pm_pgtp='ad_text_only';</script> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta http-equiv="Pragma" content="no-cache" /><meta http-equiv="cache-control" content="no-cache" /><meta name="viewport" content="width=device-width, initial-scale=1.0" /> <noscript><link rel="stylesheet" type="text/css" href="https://www.gossipcop.com/wp-content/cache/autoptimize/css/autoptimize_single_689c98606d7f474c3dc5aa2d61a94d9c.css?v=5888v7&v=2.0.2" /></noscript><link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" type="text/css" href="https://www.gossipcop.com/wp-content/cache/autoptimize/css/autoptimize_single_689c98606d7f474c3dc5aa2d61a94d9c.css?v=5888v7&v=2.0.2" /> <noscript><link rel="stylesheet" type="text/css" href="https://www.gossipcop.com/wp-content/cache/autoptimize/css/autoptimize_single_6ae287f950b5d03f0c32a4b5eb2136e2.css?v=1.01" /></noscript><link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" type="text/css" href="https://www.gossipcop.com/wp-content/cache/autoptimize/css/autoptimize_single_6ae287f950b5d03f0c32a4b5eb2136e2.css?v=1.01" /> <noscript><link rel="stylesheet" type="text/css" media="screen and (max-width: 1005px)" href="https://www.gossipcop.com/wp-content/cache/autoptimize/css/autoptimize_single_faaf8a38bfbf628663ed2279523474bd.css?ver=1.5.1" /></noscript><link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" type="text/css" media="screen and (max-width: 1005px)" href="https://www.gossipcop.com/wp-content/cache/autoptimize/css/autoptimize_single_faaf8a38bfbf628663ed2279523474bd.css?ver=1.5.1" /><link rel="apple-touch-icon" href="https://www.gossipcop.com/wp-content/static/apple-touch-icon.png" /><link rel="shortcut icon" href="https://www.gossipcop.com/wp-content/static/favicon.ico" /><link rel="alternate" type="application/rss+xml" href="https://www.gossipcop.com/feed/" title="Gossip Cop RSS Feed" /><link rel="alternate" type="application/atom+xml" href="https://www.gossipcop.com/feed/atom/" title="Gossip Cop Atom Feed" /><link rel="pingback" href="https://www.gossipcop.com/xmlrpc.php" /> <script type="text/javascript">window._taboola = window._taboola || [];
			
			if (!_lmiConfig.removeTaboola) {
				!function (e, f, u) {
					e.async = 1;
					e.src = u;
					f.parentNode.insertBefore(e, f);
				}(document.createElement('script'), document.getElementsByTagName('script')[0], 'https://cdn.taboola.com/libtrc/gossipcop/loader.js');
			}</script> <script src="//dc8xl0ndzn2cb.cloudfront.net/js/gossipcopcom/v0/keywee.min.js" type="text/javascript" async></script> <noscript></noscript> <noscript></noscript> <noscript><link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/5.11.2/css/fontawesome.min.css" rel="stylesheet"></noscript><link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/5.11.2/css/fontawesome.min.css" rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'"></style> <noscript><link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/5.11.2/css/brands.min.css" rel="stylesheet"></noscript><link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/5.11.2/css/brands.min.css" rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'"></style> <noscript><link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/5.11.2/css/solid.css" rel="stylesheet"></noscript><link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/5.11.2/css/solid.css" rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'"></style> <noscript><link rel="stylesheet" type="text/css" href="https://www.gossipcop.com/wp-content/cache/autoptimize/css/autoptimize_single_13b1b6672b8cfb0d9ae7f899f1c42875.css"/></noscript><link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" type="text/css" href="https://www.gossipcop.com/wp-content/cache/autoptimize/css/autoptimize_single_13b1b6672b8cfb0d9ae7f899f1c42875.css" /> <noscript><link rel="stylesheet" type="text/css" href="https://www.gossipcop.com/wp-content/cache/autoptimize/css/autoptimize_single_f9faba678c4d6dcfdde69e5b11b37a2e.css"/></noscript><link rel='preload' as='style' onload="this.onload=null;this.rel='stylesheet'" type="text/css" href="https://www.gossipcop.com/wp-content/cache/autoptimize/css/autoptimize_single_f9faba678c4d6dcfdde69e5b11b37a2e.css" /><style>#unit-header-wrapper {
			height: auto;
		}</style> <script defer src='https://www.googletagservices.com/tag/js/gpt.js'></script> <script>window.googletag = window.googletag || {};
  googletag.cmd = googletag.cmd || [];
  window.pbjs = window.pbjs || {};
  pbjs.que = pbjs.que || [];</script> <style>/*<![CDATA[*/[id^="div-gpt"], #bottom-anchor-fixed { display: none; }

	#home.device-mobile #posts > .post { padding: 0 !important; }

	.ad_slot {
	    display: flex;
	    flex-direction: column;
	    justify-content: center;
	    text-align: center;
	    position: relative;
	    min-height: 0;
	    clear: both;
	    float: none;
	}
	.ad_slot.ad--gam-rendered,
	.ad_slot[style*="min-height"] {
	    margin: 20px auto;
	}
	.ad_slot .ad_slot_target {
	    position: sticky;
	    top: 0;
	    bottom: 0;
	    height: auto !important;
		overflow: hidden;
	}
	.ad_slot .ad_slot_target * {
	    pointer-events: auto;
	}

	.ad_slot.ad_inline,
	.ad_slot.ad_labeled {
	    margin: 25px auto 15px;
	    min-height: 50px;
	    border-top: 1px solid #f6f6f6;
	    border-bottom: 1px solid #f6f6f6;
	    border-image: linear-gradient(to right, rgba(245,245,245,0), rgba(245,245,245,1), rgba(245,245,245,0)) 1;
	}
	.ad_slot.ad_labeled:after,
	.ad_slot.ad_inline:after {
	    opacity: 1.0;
	    transition: opacity 0.3s ease;
	    content: "advertisement";
	    position: absolute;
	    top: 0;
	    left: 0;
	    right: 0;
	    width: 100%;
	    text-align: center;
	    font-family: Arial, sans-serif;
	    font-size: 9px;
	    line-height: 16px;
	    text-transform: uppercase;
	    letter-spacing: 0.1em;
	    color: #aaa;
	    transform: translate(0, -100%);
	}

	.ad_slot.ad_anchor {
	    display: block;
	    position: fixed;
	    bottom: 0;
	    left: 0;
	    right: 0;
	    margin: 0 auto;
	    padding: 0;
	    z-index: 9999999;
	    max-height: 100px;
	    min-height: 0 !important;
	    pointer-events: none;
	}
	.ad_slot.ad_anchor_top {
	    bottom: initial;
	    top: 0;
	}

	.ad_slot.ad--prebid-win .ad_slot_target div[id^="google_ads_iframe_"] {
	    width: auto;
	    height: auto;
	    margin: auto;
	}

	.ad_slot.ad_anchor .ad_slot_target iframe[id^="google_ads_iframe_"] {
	    background: #fff;
	}

	@media (max-width: 649px) {
	  .ad_wrapper_double .ad_column_2 {
	    display: none;
	  }
	}
	@media (min-width: 650px) {
	  .ad_wrapper_double {
	    text-align: center;
	  }
	  .ad_wrapper_double .ad_column {
	    display: inline-block;
	    width: 50%;
	    max-width: 50%;
	    vertical-align: top;
	    position: sticky;
	    top: 0;
	  }
	}
	.ad_slot.ad_top {
		margin: 0 auto;
	}
	.ad_slot.ad_right_top {
		margin-top: 0;
	}
	@media (min-width: 800px) {
		.mobile {
		    display: none !important;
		}
	}
	@media (max-width: 800px) {
		#posts .post .ad_slot {
			margin-left: -15px;
			margin-right: -15px;
			margin-left: calc(-5vw);
			margin-right: calc(-5vw);
		}
	}/*]]>*/</style> <script defer src="//d3hbiib542dh57.cloudfront.net/script.js"></script> <script>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</script> <style id="fban-native-styles">/*<![CDATA[*/.device-mobile #posts .post { overflow: visible !important; }
	/* -------------- fban native styling: default fluid --------------*/
	.ad--prebid-fban-format-native {
	    padding-bottom: 0;
	}
	.ad--prebid-fban-format-native:before {
	    margin-bottom: 0;
	}
	.ad_slot.ad--prebid-fban-format-native {
	    width: auto !important;
	}
	.ad_slot.ad--prebid-fban-format-native iframe[id] {
	    width: 100% !important;
	}
	.ad_slot.ad--prebid-fban-format-native iframe[id] {
	    height: 300px !important;
	}
	/* fban native styling */
	.fban-style-default .thirdPartyRoot {
	  position: relative;
	  max-width: 414px;
	  margin: auto;
	  color: #444;
	  background-color: white;
	  font-family: sans-serif;
	  font-size: 15px;
	  line-height: 1.2em;
	  text-align: left;
	  white-space: nowrap;
	}

	.fban-style-default .thirdPartyRoot .fbAdLink {
	  display: flex;
	  flex-direction: column;
	}

	.fban-style-default .thirdPartyRoot .thirdPartyAdIconClass {
	  display: block;
	  height: 27px;
	  width: 27px;
	  border-radius: 3px;
	  overflow: hidden;
	  position: absolute;
	  bottom: 11px;
	  left: 25px;
	  box-sizing: border-box;
	  box-shadow: 0 0 5px -3px #000;
	  z-index: 999;
	}

	.fban-style-default .thirdPartyRoot .thirdPartyMediaClass {
	  height: 200px;
	  margin: 0 0 5px;
	  background: rgba(0,0,0,.05);
	  box-shadow: inset 0px 0px 50px -45px #1f4eb1;
	}

	.fban-style-default .thirdPartyRoot .thirdPartyMediaClass > img {
	  object-fit: contain;
	}

	.fban-style-default .thirdPartyRoot .thirdPartySubtitleClass {
	  font-weight: 600;
	}

	.fban-style-default .thirdPartyRoot .thirdPartySubtitleClass,
	.fban-style-default .thirdPartyRoot .fbDefaultNativeAdWrapper {
	  margin: 0 15px;
	}

	.fban-style-default .thirdPartyRoot .fbDefaultNativeAdWrapper {
	  display: flex;
	  flex-direction: column-reverse;
	  vertical-align: top;
	}

	.fban-style-default .thirdPartyRoot .thirdPartyTitleClass {
	  font-weight: 300;
	}

	.fban-style-default .thirdPartyRoot .thirdPartyTitleClass,
	.fban-style-default .thirdPartyRoot .thirdPartySubtitleClass {
	  margin-bottom: 3px;
	  overflow: hidden;
	  text-overflow: ellipsis;
	}

	.fban-style-default .thirdPartyRoot .thirdPartyCallToActionClass {
	  position: relative;
	  display: block;
	  margin: 2px 0 0;
	  border-radius: 4px;
	  padding: 10px 30px 10px 45px;
	  font-size: 18px;
	  font-weight: 400;
	  letter-spacing: 0.04em;
	  line-height: 30px;
	  text-align: center;
	  text-transform: uppercase;
	  color: #fff;
	  /* blue button */
	  background-color: #4f7ee2;
	  background: -moz-linear-gradient(top,#4f7ee2,#1f4eb1);
	  background: -ms-linear-gradient(top,#4f7ee2,#1f4eb1);
	  background: -webkit-linear-gradient(top,#4f7ee2,#1f4eb1);

	  /* green button - uncomment to use */
	  /*
	  background-color: #4fe25a;
	  background: -moz-linear-gradient(top,#4fe25a,#0c9e17);
	  background: -ms-linear-gradient(top,#4fe25a,#0c9e17);
	  background: -webkit-linear-gradient(top,#4fe25a,#0c9e17);
	   */
	}

	.fban-style-default .thirdPartyRoot .thirdPartyCallToActionClass:after {
	  content: "";
	  display: block;
	  background: url("data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAAUCAYAAACNiR0NAAAACXBIWXMAAAsTAAALEwEAmpwYAAAAdUlEQVQ4je3OvQmAMBRF4YtYWPgzj42thQM4lPsILqBO4CwWgWNhQIs0JikEPeV78HElR0ADFK7f44AO2IHZB00ct1xSKqmWNEVZCvSA4cxr6Y/+6AWWwGZBA7Sh2HzD+lBs+Qa2xsKqd2IWHKJhFsyA0Rc7APxJQKc9BEBGAAAAAElFTkSuQmCC")
	    no-repeat center center;
	  width: 20px;
	  background-size: contain;
	  position: absolute;
	  right: 7px;
	  top: 0;
	  bottom: 0;
	}/*]]>*/</style></head><body id="post-906572" class="single"> <!--[if lt IE 7]><div id="unsupported-browser"> Unfortunately, your browser is outdated and no longer supported. To view this site properly, please upgrade to a more modern browser.<br /> A few suggestions: <a href="http://windows.microsoft.com/en-us/internet-explorer/products/ie/home">Internet Explorer 9</a> | <a href="http://www.mozilla.com/en-US/firefox/personal.html">Firefox</a> | <a href="http://www.google.com/chrome">Google Chrome</a> | <a href="http://www.apple.com/safari/download/">Safari</a> | <a href="http://www.opera.com/download/">Opera</a></div> <![endif]--><div id="bottom-anchor-fixed" class="mobile" style="position: fixed; bottom: 0px; left: 0px; right: 0; padding-top: 20px; z-index: 300;"><div class="ad-close-btn" style="display: block;"></div><div id='div-gpt-ad-1501895398998-0' style='height:50px; min-width:320px;'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1501895398998-0'); });</script> </div></div><div id="header-wrapper"><div id="header"><div class="mobile"> <a href="#" class="toggle-social"><i class="fas fa-bars"></i></a></div><div class="social_new"><ul><li><a href="http://www.facebook.com/GossipCop" title="Like us on Facebook" rel="nofollow" target="_blank"><i class="fab fa-facebook" aria-hidden="true"></i></a></li><li><a href="https://twitter.com/gossipcop" title="Follow @gossipcop" rel="nofollow" target="_blank"><i class="fab fa-twitter" aria-hidden="true"></i></a></li><li><a href="http://instagram.com/gossipcop/#" title="Follow on Instagram" rel="nofollow" target="_blank"><i class="fab fa-instagram" aria-hidden="true"></i></a></li><li><a href="http://pinterest.com/gossipcop/" title="Follow on Pinterest" rel="nofollow" target="_blank"><i class="fab fa-pinterest" aria-hidden="true"></i></a></li><li><a href="https://flipboard.com/@GossipCop" title="Follow on Flipboard" rel="nofollow" target="_blank"><i class="fab fa-flipboard" aria-hidden="true"></i></a></li></ul> <span class="mobile header-menu"><a href="/" class=" menu-item first">Home</a><a href="/page/2/" class=" menu-item">Page 2</a><a href="/page/3/" class=" menu-item">Page 3</a><a href="https://www.gossipcop.com/about/" class=" menu-item">About Us</a><a href="https://www.gossipcop.com/privacy/" class=" menu-item">Privacy</a><a href="https://www.gossipcop.com/user-agreement/" class=" menu-item">User Agreement</a><a href="https://www.gossipcop.com/contact/" class=" menu-item">Contact</a><a href="https://www.gossipcop.com/feed/" class="rss menu-item last">RSS</a></span></div><div class="mobile"> <a href="#" class="toggle-search"><i class="fas fa-search"></i></a></div> <a href="#" class="desktop toggle-search-desktop"><i class="fas fa-search"></i></a><div class="right-side"><form class="searchform" method="get" action="https://www.gossipcop.com/"> <input id="s" type="text" name="s" value="" placeholder="Search" /> <input class="button" type="submit" value="Search" /></form></div> <a id="logo-image" href="https://www.gossipcop.com/"> <noscript><img class="desktop" id="logo" src="https://www.gossipcop.com/wp-content/themes/gossipcop/images/horizontal-logo.png" alt="Gossip Cop" /></noscript><img class="lazyload desktop" id="logo" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://www.gossipcop.com/wp-content/themes/gossipcop/images/horizontal-logo.png" alt="Gossip Cop" /> <noscript><img class="mobile" id="logo" src="https://www.gossipcop.com/wp-content/themes/gossipcop/images/mobile-logo.png" alt="Gossip Cop" /></noscript><img class="lazyload mobile" id="logo" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://www.gossipcop.com/wp-content/themes/gossipcop/images/mobile-logo.png" alt="Gossip Cop" /> </a><div class="clearfloat"></div></div></div><div id="hot-topics"><div class="clearfloat"></div><ul id="featured-posts"><li class=""> <a href="https://www.gossipcop.com/brad-pitt-jennifer-aniston-mom-married-again/" title="Brad Pitt’s Mom Rooting For Him To Marry Jennifer Aniston Again?"> <span class="featured-post-thumb"> <noscript><img width="520" height="355" src="https://www.gossipcop.com/wp-content/uploads/2020/01/Brad-Pitt-Jennifer-Aniston-Mom-Jane-520x355.jpg" class="attachment-home-size size-home-size wp-post-image" alt="Side by side shots of Brad Pitt and his mom Jane at an awards show and Jennifer Aniston at an awards show" title="Brad Pitt’s Mom Rooting For Him To Marry Jennifer Aniston Again?" /></noscript><img width="520" height="355" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20520%20355%22%3E%3C/svg%3E' data-src="https://www.gossipcop.com/wp-content/uploads/2020/01/Brad-Pitt-Jennifer-Aniston-Mom-Jane-520x355.jpg" class="lazyload attachment-home-size size-home-size wp-post-image" alt="Side by side shots of Brad Pitt and his mom Jane at an awards show and Jennifer Aniston at an awards show" title="Brad Pitt’s Mom Rooting For Him To Marry Jennifer Aniston Again?" /> </span> <span class=" featured-category-label category-label"></span><br /> <span class="featured-post-title">Brad Pitt’s Mom Rooting For Him To Marry Jennifer Aniston Again?</span> </a></li><li class=""> <a href="https://www.gossipcop.com/john-mayer-jessica-simpson-jennifer-aniston-dated/" title="What John Mayer Had To Say About Jessica Simpson, Jennifer Aniston After They Dated"> <span class="featured-post-thumb"> <noscript><img width="520" height="355" src="https://www.gossipcop.com/wp-content/uploads/2020/01/john-mayer-jessica-simpson-jennifer-aniston-520x355.jpg" class="attachment-home-size size-home-size wp-post-image" alt="John Mayer in a black blazer on the red carpet. Jessica Simpson in a yellow dress on the red carpet. Jennifer Aniston in a black dress on the red carpet." title="What John Mayer Had To Say About Jessica Simpson, Jennifer Aniston After They Dated" /></noscript><img width="520" height="355" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20520%20355%22%3E%3C/svg%3E' data-src="https://www.gossipcop.com/wp-content/uploads/2020/01/john-mayer-jessica-simpson-jennifer-aniston-520x355.jpg" class="lazyload attachment-home-size size-home-size wp-post-image" alt="John Mayer in a black blazer on the red carpet. Jessica Simpson in a yellow dress on the red carpet. Jennifer Aniston in a black dress on the red carpet." title="What John Mayer Had To Say About Jessica Simpson, Jennifer Aniston After They Dated" /> </span> <span class=" featured-category-label category-label"></span><br /> <span class="featured-post-title">What John Mayer Had To Say About Jessica Simpson, Jennifer Aniston After They Dated</span> </a></li><li class="desktop featured-post-last"> <a href="https://www.gossipcop.com/tom-selleck-leave-blue-bloods-health-issues/" title="Did Tom Selleck Leave The Cast Of 'Blue Bloods' Due To Health Issues?"> <span class="featured-post-thumb"> <noscript><img width="520" height="355" src="https://www.gossipcop.com/wp-content/uploads/2020/01/tom-selleck-520x355.jpg" class="attachment-home-size size-home-size wp-post-image" alt="Tom Selleck wearing a dark blazer discussing &#039;Blue Bloods&#039; in New York." title="Did Tom Selleck Leave The Cast Of &#8216;Blue Bloods&#8217; Due To Health Issues?" /></noscript><img width="520" height="355" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20520%20355%22%3E%3C/svg%3E' data-src="https://www.gossipcop.com/wp-content/uploads/2020/01/tom-selleck-520x355.jpg" class="lazyload attachment-home-size size-home-size wp-post-image" alt="Tom Selleck wearing a dark blazer discussing &#039;Blue Bloods&#039; in New York." title="Did Tom Selleck Leave The Cast Of &#8216;Blue Bloods&#8217; Due To Health Issues?" /> </span> <span class=" featured-category-label category-label"></span><br /> <span class="featured-post-title">Did Tom Selleck Leave The Cast Of 'Blue Bloods' Due To Health Issues?</span> </a></li><li class="desktop"> <a href="https://www.gossipcop.com/did-anna-faris-chris-pratt-katherine-schwarzenegger-fight/" title="Did Anna Faris Fight With Chris Pratt And Katherine Schwarzenegger?"> <span class="featured-post-thumb"> <noscript><img width="520" height="355" src="https://www.gossipcop.com/wp-content/uploads/2020/01/Anna-Faris-Chris-Pratt-Katherine-Schwarzenegger-Fight-520x355.jpg" class="attachment-home-size size-home-size wp-post-image" alt="Side by side shots of Anna Faris, and Chris Pratt and Katherine Schwarzenegger" title="Did Anna Faris Fight With Chris Pratt And Katherine Schwarzenegger?" /></noscript><img width="520" height="355" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20520%20355%22%3E%3C/svg%3E' data-src="https://www.gossipcop.com/wp-content/uploads/2020/01/Anna-Faris-Chris-Pratt-Katherine-Schwarzenegger-Fight-520x355.jpg" class="lazyload attachment-home-size size-home-size wp-post-image" alt="Side by side shots of Anna Faris, and Chris Pratt and Katherine Schwarzenegger" title="Did Anna Faris Fight With Chris Pratt And Katherine Schwarzenegger?" /> </span> <span class=" featured-category-label category-label"></span><br /> <span class="featured-post-title">Did Anna Faris Fight With Chris Pratt And Katherine Schwarzenegger?</span> </a></li></ul><div class="clearfloat"></div></div><div class="mobile top-line">NEWS</div><div id="content-wrapper"><div id="content"><div id="posts"><style>@media(min-width: 801px){ .single #posts { padding-top: 0; } }</style><div class="desktop" style="margin: 0 0 20px -40px; background: #f6f6f6; padding-bottom: 20px;"><div id="div-gpt-ad-1501894811722-0" style="height:90px; width:728px; margin: auto;"> <script>googletag.cmd.push(function() { googletag.display("div-gpt-ad-1501894811722-0"); });</script> </div></div><div class="post"><div id="#unit-single-wrapper" class="mobile"></div><h1>From Wedding Rings To Natural Disasters: Paul Walker&#8217;s Legacy Of Charity</h1><div class="mobile" style="min-height: 200px;"> <noscript><img width="250" height="167" src="https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-250x167.jpg" class="mobile post-pm-thumb wp-post-image" alt="close photo of Paul Walker&#039;s face at the Fast &amp; Furious 6 premiere" srcset="https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-250x167.jpg 250w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-300x200.jpg 300w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-593x395.jpg 593w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-125x83.jpg 125w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-368x245.jpg 368w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6.jpg 615w" sizes="(max-width: 250px) 100vw, 250px" /></noscript><img width="250" height="167" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20250%20167%22%3E%3C/svg%3E' data-src="https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-250x167.jpg" class="lazyload mobile post-pm-thumb wp-post-image" alt="close photo of Paul Walker&#039;s face at the Fast &amp; Furious 6 premiere" data-srcset="https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-250x167.jpg 250w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-300x200.jpg 300w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-593x395.jpg 593w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-125x83.jpg 125w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-368x245.jpg 368w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6.jpg 615w" data-sizes="(max-width: 250px) 100vw, 250px" /></div><div id="image-place" class="desktop"></div><p class="author">By <span style="color: #263676;"> Elyse Johnson </span> | <span class="dateline">7:30 pm, February 3, 2020</span></p><div class="blurb-text"><div id="attachment_906623" style="width: 625px" class="wp-caption aligncenter first_image"><noscript><img aria-describedby="caption-attachment-906623" class="size-full wp-image-906623" src="https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6.jpg" alt="close photo of Paul Walker's face at the Fast &amp; Furious 6 premiere" width="615" height="410" srcset="https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6.jpg 615w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-250x167.jpg 250w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-300x200.jpg 300w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-593x395.jpg 593w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-125x83.jpg 125w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-368x245.jpg 368w" sizes="(max-width: 615px) 100vw, 615px" /></noscript><img aria-describedby="caption-attachment-906623" class="lazyload size-full wp-image-906623" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20615%20410%22%3E%3C/svg%3E' data-src="https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6.jpg" alt="close photo of Paul Walker's face at the Fast &amp; Furious 6 premiere" width="615" height="410" data-srcset="https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6.jpg 615w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-250x167.jpg 250w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-300x200.jpg 300w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-593x395.jpg 593w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-125x83.jpg 125w, https://www.gossipcop.com/wp-content/uploads/2020/02/Paul-Walker-FF6-368x245.jpg 368w" data-sizes="(max-width: 615px) 100vw, 615px" /><p id="caption-attachment-906623" class="wp-caption-text">(Getty Images)</p></div><p><strong>Paul Walker</strong> was more than an actor who charmed audiences with his personable smile and brilliant blue eyes. The actor was also known for his philanthropic efforts because he loved to help people. Walker was a generous giver, often known for giving to random strangers and fans.</p><p>One story in particular is when Walker anonymously gifted a ring to a couple for their engagement. In 2013, Kyle Upham recalled how he was shopping for an engagement for his then-fiancee when the couple met Walker. Walker happened to be in the store with them, but the two were initially unaware of his star status.</p><div class='mobile' id='div-gpt-ad-1526939461036-0' style='height:250px; width:300px;margin:0 auto 20px;'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1526939461036-0'); });</script> </div><p>Upham shared with Walker how he had just returned from being deployed to Iraq and was unable to get his fiancee a ring before he left, so they were now searching for one together. The couple had left the store without a ring but were shocked shortly after when one of the saleswomen chased them down in the parking lot.</p><p>&#8220;One of the ladies came out holding a bag and just simply said, &#8216;Here&#8217;s your ring,&#8217; and I think both of our mouths dropped. And I think after a couple of minutes of shell shock, it finally sunk in, and we were like, &#8216;Well how? Who bought it?&#8217; She just smiled at me and said it was better not to say,” <span style="color: #3366ff;"><a style="color: #3366ff;" href="https://wtvr.com/2013/12/04/paul-walker-wedding-ring/">the couple stated</a></span>. It was only after Walker&#8217;s sudden death that the couple shared the story.</p><h2>Paul Walker’s charity wasn&#8217;t limited to anonymous gifts</h2><p>In 2010, Walker <a href="https://roww.org/about-us/"><span style="color: #3366ff;">founded the Reach Out Worldwide (ROWW) foundation</span></a>. ROWW is an organization of first-responders and various other professionals who help when natural disasters strike various areas. Their mission is to quickly and efficiently send out help so that they are able to assist as many people as possible. The organization came to life after Walker went to Haiti in January 2010 after the country was hit with a massive earthquake.</p><p>Walker organized a relief team that helped respond to the disaster. During his time in Haiti, the actor saw the gap between the availability of needed resources and the demand for personnel in post-disaster situations, leading him to create ROWW to help bridge that gap. Walker worked with his organization in several incidents until his death in 2013.</p><p>The<em> Fast &amp; Furious</em> star <span style="color: #3366ff;"><a style="color: #3366ff;" href="https://www.gossipcop.com/vin-diesel-quitting-fast-furious-franchise-set-accident/">died in a car crash</a></span> after leaving a charity event for ROWW. The foundation was holding a fundraiser for the victims of the Typhoon Haiyan (Yolanda). Walker and his friend, Roger Rodas, both died in the crash. The ROWW has since been under the supervision of his brother, Cody, and it continues to honor Walker’s legacy by furthering Walker’s vision to help those in need.</p></div><p class="social_buttons" style="clear:both;"> <a class="share share_facebook" target="_blank" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.gossipcop.com%2Fpaul-walker-legacy-charity-wedding-rings-natural-disasters%2F"> <i class="fab fa-facebook-f"></i><span>Share on Facebook</span> </a> <a class="share share_twitter" target="_blank" href="https://www.twitter.com/share?url=https%3A%2F%2Fwww.gossipcop.com%2Fpaul-walker-legacy-charity-wedding-rings-natural-disasters%2F&text=From%20Wedding%20Rings%20To%20Natural%20Disasters%3A%20Paul%20Walker%E2%80%99s%20Legacy%20Of%20Charity"> <i class="fab fa-twitter"></i><span>Share on Twitter</span> </a> <a class="share share_flipboard" target="_blank" href="https://share.flipboard.com/bookmarklet/popout?v=2&url=https%3A%2F%2Fwww.gossipcop.com%2Fpaul-walker-legacy-charity-wedding-rings-natural-disasters%2F&title=From%20Wedding%20Rings%20To%20Natural%20Disasters%3A%20Paul%20Walker%E2%80%99s%20Legacy%20Of%20Charity"> <i class="fab fa-flipboard"></i><span>Share on Flipboard</span> </a> <a class="share share_email" target="_blank" href="/cdn-cgi/l/email-protection#457a3630272f2026317803372a28607775122021212c2b22607775172c2b2236607775112a6077750b243130372429607775012c36243631203736607604607775152430296077751224292e2037600077607d75607c7c3660777509202224263c6077750a23607775062d24372c313c63272a213c782d313135366076046077036077033232326b222a36362c35262a356b262a2860770335243029683224292e20376829202224263c68262d24372c313c68322021212c2b2268372c2b2236682b24313037242968212c36243631203736607703"> <i class="fas fa-envelope"></i><span>Share via Email</span> </a></p><p class="tags"></p><p class="newsletter-tease"></p><div id="pm-story-unit"></div> <br class="responsive clearfix" /><div id="related-posts" class="stt-related-posts"><h2 class="title">Related Articles</h2><div class="related-posts-wrapper"><div class="related-post"> <a href="https://www.gossipcop.com/brad-pitt-jennifer-aniston-movie-rumors/" title="Brad Pitt, Jennifer Aniston Movie Rumors"><div class="featured-image-wrapper" style="background-image: url('https://www.gossipcop.com/cdn-cgi/image/w=300,fit=scale-down,f=auto/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Movie-Rumors.jpg');"></div><div class="title">Brad Pitt, Jennifer Aniston Movie Rumors</div> </a></div><div class="related-post"> <a href="https://www.gossipcop.com/jennifer-aniston-brad-pitt-angelina-jolie-lookalike/" title="Jennifer Aniston Upset About Brad Pitt Seeing &#8220;Angelina Jolie Lookalike&#8221;?"><div class="featured-image-wrapper" style="background-image: url('https://www.gossipcop.com/cdn-cgi/image/w=300,fit=scale-down,f=auto/wp-content/uploads/2019/04/Jennifer-Aniston-Brad-Pitt.jpg');"></div><div class="title">Jennifer Aniston Upset About Brad Pitt Seeing &#8220;Angelina Jolie Lookalike&#8221;?</div> </a></div><div class="related-post"> <a href="https://www.gossipcop.com/jennifer-aniston-brad-pitt-justin-theroux-set-record-straight/" title="Jennifer Aniston To Set &#8220;Record Straight&#8221; About Brad Pitt, Justin Theroux?"><div class="featured-image-wrapper" style="background-image: url('https://www.gossipcop.com/cdn-cgi/image/w=300,fit=scale-down,f=auto/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Justin-Theroux.jpg');"></div><div class="title">Jennifer Aniston To Set &#8220;Record Straight&#8221; About Brad Pitt, Justin Theroux?</div> </a></div><div class="related-post"> <a href="https://www.gossipcop.com/nicole-kidman-keith-urban-grammys-fight/" title="Nicole Kidman Refused To Join Keith Urban At Grammys After Huge Fight?"><div class="featured-image-wrapper" style="background-image: url('https://www.gossipcop.com/cdn-cgi/image/w=300,fit=scale-down,f=auto/wp-content/uploads/2020/02/Nicole-Kidman-Keith-Urban-Grammys-Fight.jpg');"></div><div class="title">Nicole Kidman Refused To Join Keith Urban At Grammys After Huge Fight?</div> </a></div><div class="related-post"> <a href="https://www.gossipcop.com/bryan-cranston-nearly-turned-down-malcolm-in-the-middle/" title="Why Bryan Cranston Nearly Turned Down The Role Of Hal In ‘Malcolm In The Middle’"><div class="featured-image-wrapper" style="background-image: url('https://www.gossipcop.com/cdn-cgi/image/w=300,fit=scale-down,f=auto/wp-content/uploads/2020/02/bryan-cranston-malcom-in-the-middle.jpg');"></div><div class="title">Why Bryan Cranston Nearly Turned Down The Role Of Hal In ‘Malcolm In The Middle’</div> </a></div><div class="related-post"> <a href="https://www.gossipcop.com/gwyneth-paltrow-chris-martin-dakota-johnson-foursome-brad-falchuk/" title="Gwyneth Paltrow Propositions Chris Martin And Dakota Johnson For A Foursome With Her And Brad Falchuk?"><div class="featured-image-wrapper" style="background-image: url('https://www.gossipcop.com/cdn-cgi/image/w=300,fit=scale-down,f=auto/wp-content/uploads/2020/02/Gwyneth-Paltrow-Chris-Martin-Dakota-Johnson-Foursome.jpg');"></div><div class="title">Gwyneth Paltrow Propositions Chris Martin And Dakota Johnson For A Foursome With Her And Brad Falchuk?</div> </a></div></div></div></div></div><div class="sidebars-container"><div id="sidebar" class="sidebar main"><div class="top-s"><div><div class="textwidget"><div class="sidebar-related-posts"><div class="related-post"> <a href="https://www.gossipcop.com/lady-gaga-jeremy-renner-bradley-cooper-dating-revenge/" title="Lady Gaga Dating Jeremy Renner To Get Revenge On Bradley Cooper?"><div class="related-image"> <noscript><img width="250" height="154" src="https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-250x154.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Lady Gaga Dating Jeremy Renner Bradley Cooper" srcset="https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-250x154.jpg 250w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-300x185.jpg 300w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-768x474.jpg 768w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-641x395.jpg 641w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-125x77.jpg 125w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-370x228.jpg 370w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-266x164.jpg 266w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-598x369.jpg 598w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper.jpg 913w" sizes="(max-width: 250px) 100vw, 250px" /></noscript><img width="250" height="154" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20250%20154%22%3E%3C/svg%3E' data-src="https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-250x154.jpg" class="lazyload attachment-thumbnail size-thumbnail wp-post-image" alt="Lady Gaga Dating Jeremy Renner Bradley Cooper" data-srcset="https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-250x154.jpg 250w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-300x185.jpg 300w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-768x474.jpg 768w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-641x395.jpg 641w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-125x77.jpg 125w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-370x228.jpg 370w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-266x164.jpg 266w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper-598x369.jpg 598w, https://www.gossipcop.com/wp-content/uploads/2019/04/Lady-Gaga-Dating-Jeremy-Renner-Bradley-Cooper.jpg 913w" data-sizes="(max-width: 250px) 100vw, 250px" /></div><div class="title">Lady Gaga Dating Jeremy Renner To Get Revenge On Bradley Cooper?</div> </a></div></div><div id="div-gpt-ad-1501894583683-0" style="height:250px; width:300px;"> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>googletag.cmd.push(function() {
		          googletag.display("div-gpt-ad-1501894583683-0");
		        });</script> </div></div></div></div></div><div id="sidebar-featured" class="featured"></div><div id="sidebar-lower" class="sidebar main"><style>.sidebars-container { position: absolute; top: 0; height: 100%; display: flex; flex-direction: column; }
					#sidebar-lower { flex-grow: 1; }</style><li class="widget"><div class="textwidget"><div id="tips" class="sidebar-item"><h4>Got tips? Email us:</h4> <a href="/cdn-cgi/l/email-protection#780c11080b381f170b0b11081b1708561b1715470b0d1a121d1b0c452c11080b"><span class="__cf_email__" data-cfemail="88dce1f8fbc8cfe7fbfbe1f8cbe7f8a6ebe7e5">[email&#160;protected]</span></a></div></div><div class="sidebar-related-posts"><div class="related-post"> <a href="https://www.gossipcop.com/brad-pitt-daughter-shiloh-jennifer-aniston-mom/" title="Brad Pitt’s Daughter Shiloh Calls Jennifer Aniston ‘Mommy’?"><div class="related-image"> <noscript><img width="250" height="156" src="https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-250x156.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Brad Pitt Jennifer Aniston Shiloh" srcset="https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-250x156.jpg 250w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-300x187.jpg 300w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-633x395.jpg 633w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-124x78.jpg 124w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-370x231.jpg 370w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-266x166.jpg 266w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-600x374.jpg 600w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh.jpg 743w" sizes="(max-width: 250px) 100vw, 250px" /></noscript><img width="250" height="156" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20250%20156%22%3E%3C/svg%3E' data-src="https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-250x156.jpg" class="lazyload attachment-thumbnail size-thumbnail wp-post-image" alt="Brad Pitt Jennifer Aniston Shiloh" data-srcset="https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-250x156.jpg 250w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-300x187.jpg 300w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-633x395.jpg 633w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-124x78.jpg 124w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-370x231.jpg 370w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-266x166.jpg 266w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh-600x374.jpg 600w, https://www.gossipcop.com/wp-content/uploads/2019/04/Brad-Pitt-Jennifer-Aniston-Shiloh.jpg 743w" data-sizes="(max-width: 250px) 100vw, 250px" /></div><div class="title">Brad Pitt’s Daughter Shiloh Calls Jennifer Aniston ‘Mommy’?</div> </a></div></div></li><div class="clear"></div><div class="top-s" style="position: sticky; top: 10px;"><li class="widget"><div class="textwidget"><div><div class="sidebar-related-posts"><div class="related-post"> <a href="https://www.gossipcop.com/bradley-cooper-lady-gaga-irina-shayk-ultimatum-choose/" title="Bradley Cooper Forced To Choose Between Lady Gaga And Irina Shayk?"><div class="related-image"> <noscript><img width="250" height="324" src="https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-250x324.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Bradley Cooper Irina Shayk Lady Gaga Forced Choose" srcset="https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-250x324.jpg 250w, https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-232x300.jpg 232w, https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-305x395.jpg 305w, https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-124x161.jpg 124w, https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-189x244.jpg 189w, https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-205x266.jpg 205w, https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose.jpg 574w" sizes="(max-width: 250px) 100vw, 250px" /></noscript><img width="250" height="324" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20250%20324%22%3E%3C/svg%3E' data-src="https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-250x324.jpg" class="lazyload attachment-thumbnail size-thumbnail wp-post-image" alt="Bradley Cooper Irina Shayk Lady Gaga Forced Choose" data-srcset="https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-250x324.jpg 250w, https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-232x300.jpg 232w, https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-305x395.jpg 305w, https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-124x161.jpg 124w, https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-189x244.jpg 189w, https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose-205x266.jpg 205w, https://www.gossipcop.com/wp-content/uploads/2019/04/Bradley-Cooper-Irina-Shayk-Lady-Gaga-Forced-Choose.jpg 574w" data-sizes="(max-width: 250px) 100vw, 250px" /></div><div class="title">Bradley Cooper Forced To Choose Between Lady Gaga And Irina Shayk?</div> </a></div></div><div id='div-gpt-ad-1501894746638-0' style='height:250px; width:300px;'> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>googletag.cmd.push(function () { googletag.display('div-gpt-ad-1501894746638-0'); });</script> </div><div id="tips" class="sidebar-item" style="margin:20px auto;"><h4>Subscribe To Our Newsletter</h4><form action="https://www.gossipcop.com/email-newsletter/" method="post"> <nobr><input id="newsinput" class="subscribe-email-widget" type="text" name="subscribe" placeholder="Your E-mail Address"></input> <input type="submit" value="Subscribe" alt="Subscribe" name="submit" class="subscribe-button-widget"></input></nobr></form></div></div></div></li><div class="clear"></div></div></div></div></div></div><div class="desktop" id="desktop_bottom_ad"></div><div id="footer"><p id="credits"> <strong>&copy; 2020 Gossip Cop Media</strong><span class="desktop"> | <a href="https://www.gossipcop.com/about/">About Us</a> | <a href="https://www.gossipcop.com/email-newsletter/">Newsletter</a> | <a href="https://www.gossipcop.com/privacy/">Privacy</a> | <a href="https://www.gossipcop.com/user-agreement/">User Agreement</a> | <a href="https://www.gossipcop.com/contact/">Contact</a> | <a href="https://www.gossipcop.com/rss/"><noscript><img src="https://www.gossipcop.com/wp-content/themes/gossipcop/images/rss.png" alt="RSS" /></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://www.gossipcop.com/wp-content/themes/gossipcop/images/rss.png" alt="RSS" /> RSS</a></span></p></div> <style>.lazyload,.lazyloading{opacity:0;}.lazyloaded{opacity:1;transition:opacity 300ms;}</style><noscript><style>.lazyload{display:none;}</style></noscript><script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script><script async data-noptimize="1" src='https://www.gossipcop.com/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js'></script> <script type="text/javascript" src="//assets.pinterest.com/js/pinit.js"></script> <noscript><div style="display: none;"> <img src="//pixel.quantserve.com/pixel/p-1fWzpTZUaT7uy.gif" border="0" height="1" width="1" alt="Quantcast"/></div> </noscript> <script type="text/javascript">window._taboola = window._taboola || [];
	if (!_lmiConfig.removeTaboola) {
	    _taboola.push({flush: true});
	}</script> <script type="text/javascript" defer src="https://www.gossipcop.com/wp-content/cache/autoptimize/js/autoptimize_438d3525dc29c430cbb3ce3479448922.js"></script><script data-cfasync='false'>/*<![CDATA[*/!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){function e(){t.media=a}var a=t.media||"all";t.addEventListener?t.addEventListener("load",e):t.attachEvent&&t.attachEvent("onload",e),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(e,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);/*]]>*/</script><script data-cfasync='false'>!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){function e(){t.media=a}var a=t.media||"all";t.addEventListener?t.addEventListener("load",e):t.attachEvent&&t.attachEvent("onload",e),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(e,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script></body></html>