<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<script type="text/javascript">function theChampLoadEvent(e){var t=window.onload;if(typeof window.onload!="function"){window.onload=e}else{window.onload=function(){t();e()}}}</script>
<script type="text/javascript">var theChampDefaultLang = 'en_US', theChampCloseIconPath = 'https://www.gossipcop.com/wp-content/plugins/super-socializer/images/close.png';</script>
<script> var theChampSiteUrl = 'https://www.gossipcop.com', theChampVerified = 0, theChampEmailPopup = 0; </script>
<script> var theChampLoadingImgPath = 'https://www.gossipcop.com/wp-content/plugins/super-socializer/images/ajax_loader.gif'; var theChampAjaxUrl = 'https://www.gossipcop.com/wp/wp-admin/admin-ajax.php'; var theChampRedirectionUrl = 'https://www.gossipcop.com/james-charles-net-worth/184871/'; var theChampRegRedirectionUrl = 'https://www.gossipcop.com/james-charles-net-worth/184871/'; </script>
<script> var theChampFBKey = '2914652698661364', theChampSameTabLogin = '0', theChampVerified = 0; var theChampAjaxUrl = 'https://www.gossipcop.com/wp/wp-admin/admin-ajax.php'; var theChampPopupTitle = ''; var theChampEmailPopup = 0; var theChampEmailAjaxUrl = 'https://www.gossipcop.com/wp/wp-admin/admin-ajax.php'; var theChampEmailPopupTitle = ''; var theChampEmailPopupErrorMsg = ''; var theChampEmailPopupUniqueId = ''; var theChampEmailPopupVerifyMessage = ''; var theChampSteamAuthUrl = ""; var theChampCurrentPageUrl = 'https%3A%2F%2Fwww.gossipcop.com%2Fjames-charles-net-worth%2F184871%2F';  var heateorMSEnabled = 0, theChampTwitterAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Twitter&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampLineAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Line&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampLiveAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Live&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampFacebookAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Facebook&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampYahooAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Yahoo&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampGoogleAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Google&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampVkontakteAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Vkontakte&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampLinkedinAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Linkedin&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampInstagramAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Instagram&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampWordpressAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Wordpress&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampDribbbleAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Dribbble&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampGithubAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Github&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampSpotifyAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Spotify&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampKakaoAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Kakao&super_socializer_redirect_to=" + theChampCurrentPageUrl; theChampTwitchAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Twitch&super_socializer_redirect_to=" + theChampCurrentPageUrl;</script>
<script> var theChampFBKey = '2914652698661364', theChampFBLang = 'en_US', theChampFbLikeMycred = 0, theChampSsga = 0, theChampCommentNotification = 0, theChampHeateorFcmRecentComments = 0, theChampFbIosLogin = 0; </script>
<script type="text/javascript">var theChampFBCommentUrl = 'https://www.gossipcop.com/james-charles-net-worth/184871/'; var theChampFBCommentColor = ''; var theChampFBCommentNumPosts = ''; var theChampFBCommentWidth = '100%'; var theChampFBCommentOrderby = ''; var theChampCommentingTabs = "wordpress,facebook,disqus", theChampGpCommentsUrl = 'https://www.gossipcop.com/james-charles-net-worth/184871/', theChampDisqusShortname = '', theChampScEnabledTabs = 'wordpress,fb', theChampScLabel = 'Leave a reply', theChampScTabLabels = {"wordpress":"Default Comments (0)","fb":"Facebook Comments","disqus":"Disqus Comments"}, theChampGpCommentsWidth = 0, theChampCommentingId = 'respond'</script>
<script> var theChampSharingAjaxUrl = 'https://www.gossipcop.com/wp/wp-admin/admin-ajax.php', heateorSsFbMessengerAPI = 'https://www.facebook.com/dialog/send?app_id=2914652698661364&display=popup&link=%encoded_post_url%&redirect_uri=%encoded_post_url%',heateorSsWhatsappShareAPI = 'web', heateorSsUrlCountFetched = [], heateorSsSharesText = 'Shares', heateorSsShareText = 'Share', theChampPluginIconPath = 'https://www.gossipcop.com/wp-content/plugins/super-socializer/images/logo.png', theChampHorizontalSharingCountEnable = 0, theChampVerticalSharingCountEnable = 0, theChampSharingOffset = -10, theChampCounterOffset = -10, theChampMobileStickySharingEnabled = 0, heateorSsCopyLinkMessage = "Link copied.";
		var heateorSsVerticalSharingShortUrl = "https://www.gossipcop.com/james-charles-net-worth/184871/";		</script>
<style type="text/css">.the_champ_horizontal_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_horizontal_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_horizontal_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	.the_champ_vertical_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_vertical_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_vertical_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	@media screen and (max-width:783px){.the_champ_vertical_sharing{display:none!important}}</style>

<title>James Charles Net Worth: Will His Controversies Impact His Bottom Line?</title>
<meta name="description" content="James Charles has been a spokesperson for Covergirl and many other beauty and makeup products. But will his scandals impact his massive net worth?" />
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.gossipcop.com/james-charles-net-worth/184871/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="James Charles Net Worth: Will His Controversies Impact His Bottom Line?" />
<meta property="og:description" content="James Charles has been a spokesperson for Covergirl and many other beauty and makeup products. But will his scandals impact his massive net worth?" />
<meta property="og:url" content="https://www.gossipcop.com/james-charles-net-worth/184871/" />
<meta property="og:site_name" content="Gossip Cop" />
<meta property="article:publisher" content="https://www.facebook.com/GossipCop/" />
<meta property="article:published_time" content="2021-04-20T23:00:34+00:00" />
<meta property="article:modified_time" content="2021-04-20T13:46:18+00:00" />
<meta property="og:image" content="https://upload.gossipcop.com/gc/uploads/2021/04/James-Charles.jpg" />
<meta property="og:image:width" content="1456" />
<meta property="og:image:height" content="960" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@GossipCop" />
<meta name="twitter:site" content="@GossipCop" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Justin Smith">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="6 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.gossipcop.com/#organization","name":"Gossip Cop","url":"https://www.gossipcop.com/","sameAs":["https://www.facebook.com/GossipCop/","https://www.instagram.com/gossipcop/","https://www.pinterest.com/gossipcop/","https://twitter.com/GossipCop"],"logo":{"@type":"ImageObject","@id":"https://www.gossipcop.com/#logo","inLanguage":"en-US","url":"https://upload.gossipcop.com/gc/uploads/2021/02/publisher-wordmark-black.png","width":340,"height":54,"caption":"Gossip Cop"},"image":{"@id":"https://www.gossipcop.com/#logo"}},{"@type":"WebSite","@id":"https://www.gossipcop.com/#website","url":"https://www.gossipcop.com/","name":"Gossip Cop","description":"Honest Celebrity News &amp; Gossip","publisher":{"@id":"https://www.gossipcop.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.gossipcop.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.gossipcop.com/james-charles-net-worth/184871/#primaryimage","inLanguage":"en-US","url":"https://upload.gossipcop.com/gc/uploads/2021/04/James-Charles.jpg","width":1456,"height":960,"caption":"(Kathy Hutchins / Shutterstock.com)"},{"@type":"WebPage","@id":"https://www.gossipcop.com/james-charles-net-worth/184871/#webpage","url":"https://www.gossipcop.com/james-charles-net-worth/184871/","name":"James Charles Net Worth: Will His Controversies Impact His Bottom Line?","isPartOf":{"@id":"https://www.gossipcop.com/#website"},"primaryImageOfPage":{"@id":"https://www.gossipcop.com/james-charles-net-worth/184871/#primaryimage"},"datePublished":"2021-04-20T23:00:34+00:00","dateModified":"2021-04-20T13:46:18+00:00","description":"James Charles has been a spokesperson for Covergirl and many other beauty and makeup products. But will his scandals impact his massive net worth?","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.gossipcop.com/james-charles-net-worth/184871/"]}]},{"@type":["Article","NewsArticle"],"@id":"https://www.gossipcop.com/james-charles-net-worth/184871/#article","isPartOf":{"@id":"https://www.gossipcop.com/james-charles-net-worth/184871/#webpage"},"author":{"@id":"https://www.gossipcop.com/#/schema/person/a4db44f70df4babc9fa1f677d4be478d"},"headline":"James Charles Net Worth: Will His Controversies Impact His Bottom Line?","datePublished":"2021-04-20T23:00:34+00:00","dateModified":"2021-04-20T13:46:18+00:00","mainEntityOfPage":{"@id":"https://www.gossipcop.com/james-charles-net-worth/184871/#webpage"},"publisher":{"@id":"https://www.gossipcop.com/#organization"},"image":{"@id":"https://www.gossipcop.com/james-charles-net-worth/184871/#primaryimage"},"articleSection":"Celebrities","inLanguage":"en-US","copyrightYear":"2021","copyrightHolder":{"@id":"https://www.gossipcop.com/#organization"}},{"@type":"Person","@id":"https://www.gossipcop.com/#/schema/person/a4db44f70df4babc9fa1f677d4be478d","name":"Justin Smith","image":{"@type":"ImageObject","@id":"https://www.gossipcop.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/31ae41e33676d79498912427655d3d48?s=96&d=mm&r=g","caption":"Justin Smith"}}]}</script>

<script>window.quillt={"consent":{"provider":"quantcast","country":"US","gdpr_applies":false,"ccpa_applies":null},"infinite_scroll":{"root_margin":"0px 0px -75% 0px"},"site":"GC","device":"desktop","content_id":184871,"content_type":"post","lmi":5,"page":"single"};window.quillt.rand=Math.random();Object.freeze(window.quillt);</script>
<link rel='preconnect' href='https://www.googletagmanager.com' />
<link rel='preconnect' href='https://fonts.googleapis.com' />
<link rel='preconnect' href='https://upload.gossipcop.com' />
<link rel="alternate" type="application/rss+xml" title="Gossip Cop &raquo; Feed" href="https://www.gossipcop.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Gossip Cop &raquo; Comments Feed" href="https://www.gossipcop.com/comments/feed/" />
<link rel="preload" as="fetch" crossorigin href="https://apis.quantcast.mgr.consensu.org/geoip" /><link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='wp-block-library-css' href='https://www.gossipcop.com/wp/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' media='all' />
<noscript><link rel='stylesheet' id='wp-block-library-css'  href='https://www.gossipcop.com/wp/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='elasticpress-related-posts-block-css' href='https://www.gossipcop.com/wp-content/plugins/elasticpress/dist/css/related-posts-block-styles.min.css?ver=3.5.2' media='all' />
<noscript><link rel='stylesheet' id='elasticpress-related-posts-block-css'  href='https://www.gossipcop.com/wp-content/plugins/elasticpress/dist/css/related-posts-block-styles.min.css?ver=3.5.2' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='qc-choice-css' href='https://www.gossipcop.com/wp-content/plugins/quantcast-choice/public/css/style.min.css?ver=2.0.4' media='all' />
<noscript><link rel='stylesheet' id='qc-choice-css'  href='https://www.gossipcop.com/wp-content/plugins/quantcast-choice/public/css/style.min.css?ver=2.0.4' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='corporate-footer-css' href='https://www.gossipcop.com/wp-content/plugins/quillt/assets/corpfooter/corpfooter.css?ver=dc8401b1e946ae95359b' media='all' />
<noscript><link rel='stylesheet' id='corporate-footer-css'  href='https://www.gossipcop.com/wp-content/plugins/quillt/assets/corpfooter/corpfooter.css?ver=dc8401b1e946ae95359b' media='all' />
</noscript>
<link rel='stylesheet' id='gossipcop-css' href='https://www.gossipcop.com/wp-content/themes/gossipcop/css/style.css?ver=b3aafbaacbcaa12f9eb2' media='all' />
<style id="gossipcop-fonts-css" media="all">@font-face {
  font-family: 'Playfair Display';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/playfairdisplay/v22/nuFvD-vYSZviVYUb_rj3ij__anPXJzDwcbmjWBN2PKdFvUDQ.ttf) format('truetype');
}
@font-face {
  font-family: 'Playfair Display';
  font-style: normal;
  font-weight: 500;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/playfairdisplay/v22/nuFvD-vYSZviVYUb_rj3ij__anPXJzDwcbmjWBN2PKd3vUDQ.ttf) format('truetype');
}
@font-face {
  font-family: 'Playfair Display';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/playfairdisplay/v22/nuFvD-vYSZviVYUb_rj3ij__anPXJzDwcbmjWBN2PKeiukDQ.ttf) format('truetype');
}
@font-face {
  font-family: 'Playfair Display';
  font-style: normal;
  font-weight: 900;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/playfairdisplay/v22/nuFvD-vYSZviVYUb_rj3ij__anPXJzDwcbmjWBN2PKfsukDQ.ttf) format('truetype');
}
</style>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='dashicons-css' href='https://www.gossipcop.com/wp/wp-includes/css/dashicons.min.css?ver=5.5.3' media='all' />
<noscript><link rel='stylesheet' id='dashicons-css'  href='https://www.gossipcop.com/wp/wp-includes/css/dashicons.min.css?ver=5.5.3' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='thickbox-css' href='https://www.gossipcop.com/wp/wp-includes/js/thickbox/thickbox.css?ver=5.5.3' media='all' />
<noscript><link rel='stylesheet' id='thickbox-css'  href='https://www.gossipcop.com/wp/wp-includes/js/thickbox/thickbox.css?ver=5.5.3' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='the_champ_frontend_css-css' href='https://www.gossipcop.com/wp-content/plugins/super-socializer/css/front.css?ver=7.13.11' media='all' />
<noscript><link rel='stylesheet' id='the_champ_frontend_css-css'  href='https://www.gossipcop.com/wp-content/plugins/super-socializer/css/front.css?ver=7.13.11' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='the_champ_sharing_default_svg-css' href='https://www.gossipcop.com/wp-content/plugins/super-socializer/css/share-svg.css?ver=7.13.11' media='all' />
<noscript><link rel='stylesheet' id='the_champ_sharing_default_svg-css'  href='https://www.gossipcop.com/wp-content/plugins/super-socializer/css/share-svg.css?ver=7.13.11' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='aawp-css' href='https://www.gossipcop.com/wp-content/plugins/aawp/assets/dist/css/main.css?ver=3.15.1' media='all' />
<noscript><link rel='stylesheet' id='aawp-css'  href='https://www.gossipcop.com/wp-content/plugins/aawp/assets/dist/css/main.css?ver=3.15.1' media='all' />
</noscript>
<link rel="preload" href="https://upload.gossipcop.com/gc/uploads/2021/04/James-Charles-702x526.jpg" as="image">
<script id='qc-choice-js-extra'>
var choice_cmp_config = {"utid":"A9b8GRq-NyEYK","enabled":"all","ccpa":"manual","datalayer":"true"};
</script>
<script async="async" src='https://www.gossipcop.com/wp-content/plugins/quantcast-choice/public/js/script.min.js?ver=2.0.4' id='qc-choice-js'></script>
<script src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/consent/consentwrapper.js?ver=51b107c8b7f515762994' id='consentwrapper-js'></script>
<script src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/consent/consentwrapper_init.js?ver=1280692c4fea4eb0db48' id='consentwrapper_init-js'></script>
<script src='https://www.gossipcop.com/wp/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/themes/gossipcop/js/theme.js?ver=9cdb1e546d0e98b6f37a' id='gossipcop-js'></script>
<script src='https://www.googletagmanager.com/gtag/js?id=UA-45900089-1' id='google_gtagjs-js' async></script>
<script id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.gossipcop.com"]} );
gtag('js', new Date());
gtag('set', 'developer_id.dZTNiMT', true);
gtag('config', 'UA-45900089-1', {"anonymize_ip":true,"dimension1":5,"dimension3":184871} );
</script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.gossipcop.com/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.gossipcop.com/wp/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.5.3" />
<style type="text/css">.aawp .aawp-tb__row--highlight{background-color:#256aaf;}.aawp .aawp-tb__row--highlight{color:#256aaf;}.aawp .aawp-tb__row--highlight a{color:#256aaf;}</style><meta name="generator" content="Site Kit by Google 1.22.0" /><link rel=preload as=fetch crossorigin href='/api/info/'><link rel="amphtml" href="https://www.gossipcop.com/james-charles-net-worth/184871/?amp"><style>
</style>
<link rel="icon" href="https://upload.gossipcop.com/gc/uploads/2021/01/gc_favicon_16.png" sizes="32x32" />
<link rel="icon" href="https://upload.gossipcop.com/gc/uploads/2021/01/gc_favicon_16.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://upload.gossipcop.com/gc/uploads/2021/01/gc_favicon_16.png" />
<meta name="msapplication-TileImage" content="https://upload.gossipcop.com/gc/uploads/2021/01/gc_favicon_16.png" />
<link rel="preload" href="/wp-content/plugins/quantcast-choice/public/js/script.min.js?ver=2.0.4" as="script"><link rel="preload" href="/wp-content/plugins/quillt/assets/consent/consentwrapper.js?ver=51b107c8b7f515762994" as="script"><link rel="preload" href="/wp-content/plugins/quillt/assets/consent/consentwrapper_init.js?ver=1280692c4fea4eb0db48" as="script"><link rel="preload" href="/wp/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp" as="script"><link rel="preload" href="/wp-content/themes/gossipcop/js/theme.js?ver=9cdb1e546d0e98b6f37a" as="script"><link rel="preload" href="/wp/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3" as="style"><link rel="preload" href="/wp-content/plugins/elasticpress/dist/css/related-posts-block-styles.min.css?ver=3.5.2" as="style"><link rel="preload" href="/wp-content/plugins/quantcast-choice/public/css/style.min.css?ver=2.0.4" as="style"><link rel="preload" href="/wp-content/plugins/quillt/assets/corpfooter/corpfooter.css?ver=dc8401b1e946ae95359b" as="style"><link rel="preload" href="/wp-content/themes/gossipcop/css/style.css?ver=b3aafbaacbcaa12f9eb2" as="style"><link rel="preload" href="/wp/wp-includes/css/dashicons.min.css?ver=5.5.3" as="style"><link rel="preload" href="/wp/wp-includes/js/thickbox/thickbox.css?ver=5.5.3" as="style"><link rel="preload" href="/wp-content/plugins/super-socializer/css/front.css?ver=7.13.11" as="style"><link rel="preload" href="/wp-content/plugins/super-socializer/css/share-svg.css?ver=7.13.11" as="style"><link rel="preload" href="/wp-content/plugins/aawp/assets/dist/css/main.css?ver=3.15.1" as="style"> <link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/quillt/assets/batsignal/aws-sdk.2.190.0.min.js?ver=4f1a5556647321da9441" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/quillt/assets/batsignal/batsignal_js.min.js?ver=39d9f96a10a7bfcdf6e4" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/quillt/assets/inf_scroll.js?ver=1ec442bf23a1be3b318f" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.3.3" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.3.3" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/quillt/assets/outbrain.js?ver=d201f3e1c67279e4bbc3" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/social_login/general.js?ver=7.13.11" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/social_login/common.js?ver=7.13.11" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/facebook/sdk.js?ver=7.13.11" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/facebook/commenting.js?ver=7.13.11" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/sharing/sharing.js?ver=7.13.11" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/themes/genesis/lib/js/menu/responsive-menus.min.js?ver=1.1.3" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/aawp/assets/dist/js/main.js?ver=3.15.1" />
</head>
<body class="post-template-default single single-post postid-184871 single-format-standard wp-embed-responsive aawp-custom header-full-width content-sidebar genesis-breadcrumbs-hidden genesis-singular-image-visible genesis-footer-widgets-hidden first-block-core-paragraph"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://www.gossipcop.com/">Gossip Cop</a></p><p class="site-description">Honest Celebrity News &amp; Gossip</p></div><nav class="nav-primary genesis-responsive-menu" aria-label="Main" id="genesis-nav-primary"><div class="wrap"><ul id="menu-header-nav" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-159223" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-159223"><a href="https://www.gossipcop.com/c/news/"><span>News <div class="mobile-only category-extras"> <span class="description mobile-only"> The latest in celebrity gossip </span> <img class="image mobile-only" loading="lazy" src="https://upload.gossipcop.com/gc/uploads/2021/01/news.jpg" /></div></span></a></li>
<li id="menu-item-159224" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-159224"><a href="https://www.gossipcop.com/c/entertainment/"><span>Entertainment <div class="mobile-only category-extras"> <span class="description mobile-only"> Hollywood and beyond </span> <img class="image mobile-only" loading="lazy" src="https://upload.gossipcop.com/gc/uploads/2021/01/entertainment.jpg" /></div></span></a></li>
<li id="menu-item-159222" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-159222"><a href="https://www.gossipcop.com/c/celebrities/"><span>Celebrities <div class="mobile-only category-extras"> <span class="description mobile-only"> Your favorite stars from A to Z </span> <img class="image mobile-only" loading="lazy" src="https://upload.gossipcop.com/gc/uploads/2021/01/celebrities.jpg" /></div></span></a></li>
<li id="menu-item-159225" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-159225"><a href="https://www.gossipcop.com/c/royals/"><span>Royal Family <div class="mobile-only category-extras"> <span class="description mobile-only"> Latest news from the House Of Windsor </span> <img class="image mobile-only" loading="lazy" src="https://upload.gossipcop.com/gc/uploads/2021/01/royal.jpg" /></div></span></a></li>
<li id="menu-item-159226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-159226"><a href="https://www.gossipcop.com/c/baby-buzz/"><span>Baby Buzz <div class="mobile-only category-extras"> <span class="description mobile-only"> Who in Hollywood is having a baby? </span> <img class="image mobile-only" loading="lazy" src="https://upload.gossipcop.com/gc/uploads/2021/01/babybuzz.jpg" /></div></span></a></li>
<li class="primary-extras menu-item"><div class="header-search"><div id="primary-search-container" class="search-container"><form class="search-form" method="get" action="https://www.gossipcop.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-1">search</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="search"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.gossipcop.com/?s={s}"></form> <button type="button" class="header-search-button" id="toggleSearchForm"></button> </div></div> <div class="header-subscribe"><a href="https://www.gossipcop.com/newsletter/" id="subscribe-link"><span>Subscribe</span></a></div></li><li class="social-icons menu-item"><div class="share-heading">FOLLOW US</div><ul class="social-block"><li class="facebook"><a target="_blank" href="https://www.facebook.com/GossipCop/"></a></li> <li class="twitter"><a target="_blank" href="https://twitter.com/GossipCop" data-show-count="false" data-show-screen-name="false"></a></li> <li class="pinterest"><a target="_blank" href="https://www.pinterest.com/gossipcop/"></a></li> <li class="instagram"><a target="_blank" href="https://www.instagram.com/gossipcop/"></a></li> <li class="flipboard"><a data-flip-widget="ico" href="https://flipboard.com/@GossipCop?utm_campaign=tools&utm_medium=follow&action=follow&utm_source=www.gossipcop.com" target="_blank"></a><script defer src="https://cdn.flipboard.com/web/buttons/js/flbuttons.min.js"></script></li></ul></li></ul></div></nav><div class="mobile header-search"><div id="mobile-search-container" class="search-container"><form class="search-form" method="get" action="https://www.gossipcop.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-2">search</label><input class="search-form-input" type="search" name="s" id="searchform-2" placeholder="search"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.gossipcop.com/?s={s}"></form> <button type="button" class="header-search-button" id="toggleMobileSearchForm"></button> </div> </div></div></header><div class='content-related-block related-carousel'>
<div class='post-related'>
<a class="post-related-post post-185054 post type-post status-publish format-standard has-post-thumbnail category-celebrities tag-kaley-cuoco entry" id="post-185054" href='https://www.gossipcop.com/reports-say-kaley-cuoco-and-her-husband-are-struggling-under-quarantine/185054/'>
<div class='post-related-content'>
<span class='post-related-image'>
<img width="150" height="92" src="https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_536229106-150x92.jpg" class="attachment-thumbnail-scaled size-thumbnail-scaled" alt="Kaley Cuoco in a pink dress and Karl Cook in a tuxedo" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_536229106-150x92.jpg 150w, https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_536229106-300x185.jpg 300w, https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_536229106-1024x630.jpg 1024w, https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_536229106-768x472.jpg 768w, https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_536229106.jpg 1200w" sizes="(max-width: 150px) 100vw, 150px" /> </span>
<span class='post-related-category'>
Celebrities </span>
<span class='post-related-title'>
Reports Say Kaley Cuoco And Her Husband Are Struggling Under Quarantine </span>
<span class='post-related-summary'>
<p>Kaley Cuoco and Karl Cook have had an eventful year. Cuoco received critical acclaim for The Flight Attendant, but more importantly, the two finally moved in together. According to the tabloids, Cuoco and Cook have been at each other’s throats. Here are some stories Gossip Cop has investigated about the couple struggling in quarantine. Clash [&hellip;]</p> </span>
<span class='post-related-author'>
by Matthew Radulski </span>
</div>
</a>
<a class="post-related-post post-184871 post type-post status-publish format-standard has-post-thumbnail category-celebrities entry" id="post-184871" href='https://www.gossipcop.com/james-charles-net-worth/184871/'>
<div class='post-related-content'>
<span class='post-related-image'>
<img width="150" height="99" src="https://upload.gossipcop.com/gc/uploads/2021/04/James-Charles-150x99.jpg" class="attachment-thumbnail-scaled size-thumbnail-scaled" alt="James Charles wearing a white jacket." loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/James-Charles-150x99.jpg 150w, https://upload.gossipcop.com/gc/uploads/2021/04/James-Charles-300x198.jpg 300w, https://upload.gossipcop.com/gc/uploads/2021/04/James-Charles-1024x675.jpg 1024w, https://upload.gossipcop.com/gc/uploads/2021/04/James-Charles-768x506.jpg 768w, https://upload.gossipcop.com/gc/uploads/2021/04/James-Charles.jpg 1456w" sizes="(max-width: 150px) 100vw, 150px" /> </span>
<span class='post-related-category'>
Celebrities </span>
<span class='post-related-title'>
James Charles Net Worth: Will His Controversies Impact His Bottom Line? </span>
<span class='post-related-summary'>
<p>James Charles has been a spokesperson for Covergirl and many other beauty and makeup products. But will his scandals impact his massive net worth?</p> </span>
<span class='post-related-author'>
by Justin Smith </span>
</div>
</a>
<a class="post-related-post post-184914 post type-post status-publish format-standard has-post-thumbnail category-entertainment entry" id="post-184914" href='https://www.gossipcop.com/report-aaron-rodgers-now-second-choice-in-running-for-permanent-jeopardy-host/184914/'>
<div class='post-related-content'>
<span class='post-related-image'>
<img width="150" height="100" src="https://upload.gossipcop.com/gc/uploads/2021/04/aaron-rodgers-jeopardy-150x100.jpg" class="attachment-thumbnail-scaled size-thumbnail-scaled" alt="screenshot of Aaron Rodgers on Jeopardy!" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/aaron-rodgers-jeopardy-150x100.jpg 150w, https://upload.gossipcop.com/gc/uploads/2021/04/aaron-rodgers-jeopardy-300x200.jpg 300w, https://upload.gossipcop.com/gc/uploads/2021/04/aaron-rodgers-jeopardy-1024x683.jpg 1024w, https://upload.gossipcop.com/gc/uploads/2021/04/aaron-rodgers-jeopardy-768x512.jpg 768w, https://upload.gossipcop.com/gc/uploads/2021/04/aaron-rodgers-jeopardy.jpg 1200w" sizes="(max-width: 150px) 100vw, 150px" /> </span>
<span class='post-related-category'>
Entertainment </span>
<span class='post-related-title'>
Report: Aaron Rodgers Now Second Choice In Running For Permanent &#8216;Jeopardy!&#8217; Host </span>
<span class='post-related-summary'>
<p>Aaron Rodgers&#8216; brief stint as host of Jeopardy! won over plenty of fans, but did it seal the deal for his future with the show? One outlet says that Rodgers only has one person to worry about in his campaign to become the permanent host. Here&#8217;s what we know. Aaron Rodgers Is The Front-Runner &#8220;Rodgers [&hellip;]</p> </span>
<span class='post-related-author'>
by Griffin Matis </span>
</div>
</a>
<a class="post-related-post post-185180 post type-post status-publish format-standard has-post-thumbnail category-celebrities tag-katie-holmes entry" id="post-185180" href='https://www.gossipcop.com/katie-holmes-credits-this-drugstore-moisturizer-for-keeping-a-youthful-glow/185180/'>
<div class='post-related-content'>
<span class='post-related-image'>
<img width="150" height="102" src="https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_1357711709-scaled-e1618954690163-150x102.jpg" class="attachment-thumbnail-scaled size-thumbnail-scaled" alt="" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_1357711709-scaled-e1618954690163-150x102.jpg 150w, https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_1357711709-scaled-e1618954690163-300x204.jpg 300w, https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_1357711709-scaled-e1618954690163-1024x695.jpg 1024w, https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_1357711709-scaled-e1618954690163-768x521.jpg 768w, https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_1357711709-scaled-e1618954690163-1536x1043.jpg 1536w, https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_1357711709-scaled-e1618954690163.jpg 1772w" sizes="(max-width: 150px) 100vw, 150px" /> </span>
<span class='post-related-category'>
Celebrities </span>
<span class='post-related-title'>
Katie Holmes Credits This Drugstore Moisturizer For Keeping A Youthful Glow </span>
<span class='post-related-summary'>
<p>Katie Holmes is living proof that you don't need to shell out big bucks for quality products. </p> </span>
<span class='post-related-author'>
 by Laura Hohenstein </span>
</div>
</a>
</div></div><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><div class="category-breadcrumb"><a href=https://www.gossipcop.com/c/celebrities/ class="category-breadcrumb">Celebrities</a></div><article class="post-184871 post type-post status-publish format-standard has-post-thumbnail category-celebrities entry" aria-label="James Charles Net Worth: Will His Controversies Impact His Bottom Line?"><header class="entry-header"><h1 class="entry-title">James Charles Net Worth: Will His Controversies Impact His Bottom Line?</h1>
</header><div class="entry-content"><div class="author-byline"><div class="initial-bubbles"><span class="initial-box">J</span></div><a class="right-byline" href="https://www.gossipcop.com/about"><div class="authors"><span class="name">Justin Smith</span></div><div class="published-date">6:00 pm, April 20, 2021</div></a></div><figure class="cover-image"><img width="702" height="526" src="https://upload.gossipcop.com/gc/uploads/2021/04/James-Charles-702x526.jpg" class="singular-image entry-image" alt="James Charles wearing a white jacket." loading="lazy" /><figcaption class="image-attribution">(Kathy Hutchins / Shutterstock.com)</figcaption></figure><div style='clear: both'></div><div class='the_champ_sharing_container the_champ_horizontal_sharing' super-socializer-data-href="https://www.gossipcop.com/james-charles-net-worth/184871/"><div class='the_champ_sharing_title' style="font-weight:bold"></div><ul class="the_champ_sharing_ul"><li class="theChampSharingRound"><i style="width:35px;height:35px;" alt="Facebook" Title="Facebook" class="theChampSharing theChampFacebookBackground" onclick='theChampPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.gossipcop.com%2Fjames-charles-net-worth%2F184871%2F")'><ss style="display:block;" class="theChampSharingSvg theChampFacebookSvg"></ss></i></li><li class="theChampSharingRound"><i style="width:35px;height:35px;" alt="Twitter" Title="Twitter" class="theChampSharing theChampTwitterBackground" onclick='theChampPopup("http://twitter.com/intent/tweet?text=James%20Charles%20Net%20Worth%3A%20Will%20His%20Controversies%20Impact%20His%20Bottom%20Line%3F&url=https%3A%2F%2Fwww.gossipcop.com%2Fjames-charles-net-worth%2F184871%2F")'><ss style="display:block;" class="theChampSharingSvg theChampTwitterSvg"></ss></i></li><li class="theChampSharingRound"><i style="width:35px;height:35px;" alt="Flipboard" Title="Flipboard" class="theChampSharing theChampFlipboardBackground" onclick='theChampPopup("https://share.flipboard.com/bookmarklet/popout?v=2&url=https%3A%2F%2Fwww.gossipcop.com%2Fjames-charles-net-worth%2F184871%2F&title=James%20Charles%20Net%20Worth%3A%20Will%20His%20Controversies%20Impact%20His%20Bottom%20Line%3F")'><ss style="display:block;" class="theChampSharingSvg theChampFlipboardSvg"></ss></i></li><li class="theChampSharingRound"><i style="width:35px;height:35px;" alt="Pinterest" Title="Pinterest" class="theChampSharing theChampPinterestBackground" onclick="javascript:void((function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());"><ss style="display:block;" class="theChampSharingSvg theChampPinterestSvg"></ss></i></li><li class="theChampSharingRound"><i style="width:35px;height:35px;" alt="Instagram" Title="Instagram" class="theChampSharing theChampInstagramBackground"><a href="https://www.instagram.com/gossipcop" target="_blank"><ss style="display:block;" class="theChampSharingSvg theChampInstagramSvg"></ss></a></i></li><li class="theChampSharingRound"><i style="width:35px;height:35px;" alt="Email" Title="Email" class="theChampSharing theChampEmailBackground" onclick="window.open('mailto:?subject=' + decodeURIComponent('James%20Charles%20Net%20Worth%3A%20Will%20His%20Controversies%20Impact%20His%20Bottom%20Line%3F' ).replace('&', '%26') + '&body=' + decodeURIComponent('https%3A%2F%2Fwww.gossipcop.com%2Fjames-charles-net-worth%2F184871%2F' ), '_blank')"><ss style="display:block" class="theChampSharingSvg theChampEmailSvg"></ss></i></li></ul><div style="clear:both"></div></div><div style='clear: both'></div><div class="entry-content-inner">
<p>YouTubers make a ridiculous amount of money, and it feels like it happens overnight. Whether you&#8217;re a beauty guru, a video game streamer, or an adult entertainer, YouTube can make you a millionaire; and <strong>James Charles</strong> is just another example of that trend.</p>
<p>But another common trend in the YouTube landscape is controversy. Some of YouTube&#8217;s biggest personalities have been involved in scandals, ranging in severity from personal beef to accusations of criminal behavior. James Charles is no exception. Since his first upload, he&#8217;s been embroiled in&nbsp;dozens of scandals&nbsp;while simultaneously earning millions of dollars. <strong>Gossip Cop</strong> is taking a deep dive into James Charles&#8217; net worth and whether his problematic tendencies will make a dent in his wallet.&nbsp;</p>
<h2 id="h-james-charles-exploded-onto-the-beauty-scene-in-2016">James Charles Exploded Onto The Beauty Scene In 2016</h2>
<p>If it feels like James Charles popped up out of the clear blue, it&#8217;s because, well, he kind of did. He started a YouTube channel in 2015, and at that point, he was just an unknown beginner. The following year, he went viral for&nbsp;<a target="_blank" href="https://twitter.com/jamescharles/status/772883439733338112" rel="noreferrer noopener">his glamorous senior photos</a>.</p>
<p>After his viral moment, Charles and his online following started to grow. He attracted the attention of CoverGirl, and he became their first-ever male spokesperson. At that point, he went from a regular beautify influencer to being a full-fledged celebrity.</p>
<figure class="wp-block-embed-instagram wp-block-embed is-type-rich is-provider-instagram"><div class="wp-block-embed__wrapper">
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/BLbN-CzAJsz/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="13" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:500px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/BLbN-CzAJsz/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> <div style=" display: flex; flex-direction: row; align-items: center;"> <div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div> <div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div> <div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"> <div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div> <div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div> <div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"> <div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div> <div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"> <div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div> <div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div> <div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div> <div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;"> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div></div></a><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;"><a href="https://www.instagram.com/p/BLbN-CzAJsz/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none;" target="_blank">A post shared by COVERGIRL (@covergirl)</a></p></div></blockquote><script async src="//platform.instagram.com/en_US/embeds.js"></script>
</div></figure>
<p>These days, he boasts over 25 million subscribers on his&nbsp;<a target="_blank" href="https://www.youtube.com/channel/UCucot-Zp428OwkyRm2I7v2Q" rel="noreferrer noopener">YouTube channel</a>, making him one of the most influential voices in the beauty industry. He even hosted a web series,&nbsp;<em>Instant Influencer,&nbsp;</em>where contestants compete to become the next big beauty superstar.&nbsp;</p>
<h2 id="h-he-has-been-involved-in-numerous-controversies">He Has Been Involved In Numerous Controversies</h2>
<p>Although he hasn&#8217;t been in the public eye for very long, the makeup guru has been involved in numerous scandals. Controversies on his rap sheet include: making racially insensitive comments about the Ebola virus, calling <a rel="noreferrer noopener" href="https://www.gossipcop.com/ariana-grandes-fans-worried-shes-too-thin-after-latest-instagram-post/182281/" target="_blank">Ariana Grande</a> &#8220;rude,&#8221; and making sexually suggestive comments towards <a rel="noreferrer noopener" href="https://www.gossipcop.com/report-shawn-mendes-camila-cabello-planning-2021-engagement/184/" target="_blank">Shawn Mendes</a> on social media. The list could go on and on.&nbsp;</p>
<p>But in 2019, a controversy with fellow YouTuber Tati Westbrook rocked the internet and seemed to put the most considerable strain on his career. Westbrook posted a lengthy video attempting to expose Charles for negative behavior. The most shocking of her accusations was that Charles was sexually manipulative and used his fame to coerce people. Other online influencers weighed in, like <a target="_blank" href="https://www.gossipcop.com/jeffree-star-admits-more-going-breakup/57332/" rel="noreferrer noopener">Jeffree Star</a>, who expressed support for Westbrook and called Charles a &#8220;<a target="_blank" href="https://www.nytimes.com/2019/05/14/style/james-charles-makeup-artist-youtube.html" rel="noreferrer noopener">danger to society</a>.&#8221;&nbsp;</p>
<p>Charles posted an apology video, but he lost over two million subscribers in the aftermath. In an influencer&#8217;s world where followers and subscriber counts directly translate into paychecks, it seemed like his career was in serious jeopardy.&nbsp;</p>
<p>Charles rebounded, and it didn&#8217;t take long. Since <a rel="noreferrer noopener" href="https://www.gossipcop.com/jeffree-star-kat-von-d-james-charles-feuds/57443/" target="_blank">the Tati Westbrook scandal</a>, he&#8217;s gained those two million followers back and then some. But more recently, Charles found himself battling another issue. </p>
<h3 id="h-the-2021-allegations">The 2021 Allegations</h3>
<p>In February 2021, <a rel="noreferrer noopener" href="https://www.insider.com/james-charles-allegations-snapchats-teens-accusations-controversy-apology-cancelled-drama-2021-4" target="_blank">a 16-year-old boy alleged that Charles groomed him</a> and pressured him into exchanging sexual photos on Snapchat. Charles responded to the allegations, claiming that he was not aware of the person&#8217;s age at the time of their interaction. Still, that wasn&#8217;t his last time getting called out for this type of behavior.</p>
<p>Over the following weeks, more young boys came forward&nbsp;to describe their interactions with the influencer, describing sexually charged conversations that didn&#8217;t stop once Charles became aware of their ages.&nbsp;</p>
<p>Following the explosive allegations, Charles shared a video to his YouTube page called &#8220;holding myself accountable.&#8221; In the video, Charles speaks in a softer-than-usual voice before apologizing to the minors. He asserts that he didn&#8217;t understand the gravity of his behavior and acknowledges that his online conversations were inappropriate. &#8220;It&#8217;s gross, it&#8217;s weird, and it&#8217;s desperation,&#8221; he reflected.&nbsp;</p>
<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="holding myself accountable" width="500" height="281" src="https://www.youtube.com/embed/GsjwRp8_lWA?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div></figure>
<h2 id="h-james-charles-is-worth-22-million">James Charles Is Worth $22 Million</h2>
<p>James Charles probably had no idea that his viral makeup moment from 2016 would translate into a multimillion-dollar career. But through the power of social media and YouTube, he&#8217;s amassed quite a fortune.&nbsp;<em><a href="https://www.celebritynetworth.com/richest-celebrities/models/james-charles-net-worth/" target="_blank" rel="noreferrer noopener">Celebrity Net Worth</a>&nbsp;</em>estimates that the 21-year-old star is worth $22 million.&nbsp;</p>
<p>So how did he make all of that money? His YouTube channel is the foundation of his empire. Attracting over a billion views in five years, he makes thousands of dollars every time he uploads a piece of content through advertising revenue and sponsorships. It&#8217;s quite common for YouTuber&#8217;s to make anywhere from $3-$8 for every thousand views a video gets, depending on the type of content they produce. </p>
<p>Because he has such a vast following, Charles has been able to create additional revenue streams outside of his YouTube channel. As a CoverGirl ambassador, he&#8217;s appeared in a number of their ads. Then he partnered with Morphe Cosmetics to release &#8220;The James Charles Palette,&#8221; a colorful collection of eyeshadow that retails for $39. He also launched a clothing line called Sisters Apparel.&nbsp;</p>
<p>On top of his lucrative content and merchandising, Charles has a number of brand partnerships that help contribute to his $22 million fortune. Of course, there&#8217;s Morphe and CoverGirl. But he&#8217;s also partnered with companies like Lilly Lashes and OFRA Cosmetics to promote their products and offer his followers exclusive discount codes.&nbsp;</p>
<p>With all of those revenue streams, Charles can live a lavish lifestyle. In 2020, he purchased a $7 million home in California and showed it off on his YouTube page. The six-bedroom home includes a pool house, a sauna, and a movie theater.&nbsp;</p>
<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="I Bought My First Home! 2020 House Tour 🏡" width="500" height="281" src="https://www.youtube.com/embed/prSxHZBY3CU?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div></figure>
<h2 id="h-how-will-james-charles-controversies-impact-his-net-worth">How Will James Charles&#8217; Controversies Impact His Net Worth?</h2>
<p>With a $22 million net worth and mounting pressure from his accusers, it seems like James Charles has a lot to lose. The YouTuber has rebounded from controversy in the past, but the current situation carries more weight than anything else that has threatened his career. </p>
<p>Other YouTubers, like <a rel="noreferrer noopener" href="https://www.gossipcop.com/david-dobriks-net-worth-how-the-youtuber-spends-his-money/178917/" target="_blank">David Dobrik</a> and <a rel="noreferrer noopener" href="https://www.gossipcop.com/jeffree-star-injured-in-severe-car-crash/184566/" target="_blank">Jeffree Star</a>, have been dropped from brand partnerships due to their problematic behavior. James Charles could be following in their footsteps, which would negatively impact his net worth. </p>
<p>Morphe recently announced that that they are severing ties with their longtime collaborator. </p>
<p>&#8220;In light of the recent allegations against James Charles, Morphe and James have agreed to end our business relationship and wind down sales of the Morphe x James Charles product offering,&#8221; <a href="https://twitter.com/MorpheBrushes/status/1383223698119745551" target="_blank" rel="noreferrer noopener">Morphe shared in a statement on Twitter</a>.&nbsp;</p>
<p>&#8220;It is and has always been Morphe&#8217;s goal to create a positive, safe, and empowering space where all beauty lovers can freely share their artistry and passion for cosmetics, and Morphe is committed to furthering that goal,&#8221; the statement continued. </p>
<p>YouTube had already confirmed that <a rel="noreferrer noopener" href="https://variety.com/2021/digital/news/zach-zhc-hsieh-instant-influencer-season-2-1234952164/" target="_blank">Charles will no longer be the host of <em>Instant Influencer</em></a>. Then on April 19, 2021, YouTube announced that his<a href="https://www.businessinsider.com/james-charles-demonetized-youtube-temporarily-sexting-minors-scandal-2021-4" target="_blank" rel="noreferrer noopener"> </a>channel is temporarily demonetized. <a href="https://www.businessinsider.com/james-charles-demonetized-youtube-temporarily-sexting-minors-scandal-2021-4" target="_blank" rel="noreferrer noopener">In a statement to <em>Insider</em></a>, YouTube confirmed that this action was a result of their &#8220;creator responsibility policy,&#8221; which allows them to take action against creators for harmful behavior, whether it happens on or off their platform.</p>
<p>It&#8217;s unclear how long his channel will be demonetized, but he&#8217;ll be unable to make money off of his videos until it&#8217;s lifted. We&#8217;ll continue to see if other brands will follow suit by discontinuing their partnerships. While it may be too soon to determine the exact dollar impact these recent allegations have had on James Charles&#8217; net worth, it&#8217;s safe to say that he&#8217;s taking a hit.</p>
</div></div><footer class="entry-footer"></footer></article><div class="after-entry widget-area"> <div class="outbrain-widget" data-config="{&quot;title&quot;:&quot;AR_1 &amp; inf AR_2&quot;,&quot;widget_id&quot;:&quot;AR_1&quot;,&quot;infinite&quot;:1,&quot;infinite_widget_id&quot;:&quot;AR_2&quot;,&quot;display_desktop&quot;:1,&quot;display_tablet&quot;:1,&quot;display_mobile&quot;:1,&quot;url&quot;:&quot;https:\/\/www.gossipcop.com\/james-charles-net-worth\/184871\/&quot;}"></div>
<section id="text-4" class="widget widget_text"><div class="widget-wrap"> <div class="textwidget"><script defer src="https://embed.secondstreetapp.com/Scripts/dist/optin.js" data-ss-embed="optin" data-design-id="2042795"></script>
</div>
</div></section>
</div><style type="text/css">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</style><div id="ajax-load-more" class="ajax-load-more-wrap infinite classic" data-alm-id="" data-canonical-url="https://www.gossipcop.com/james-charles-net-worth/184871/" data-slug="james-charles-net-worth" data-post-id="184871" data-localized="ajax_load_more_vars"><div aria-live="polite" aria-atomic="true" class="alm-listing alm-ajax" data-container-type="div" data-repeater="default" data-post-type="post" data-meta-key="is_published_search_list" data-meta-value="1" data-post-not-in="184871" data-vars="page_type:post" data-order="DESC" data-orderby="date" data-offset="0" data-posts-per-page="1" data-scroll="true" data-scroll-distance="-50%" data-max-pages="4" data-pause-override="true" data-pause="true" data-button-label="Load More" data-destroy-after="4"></div><div class="alm-btn-wrap" style="visibility: hidden;"><button class="alm-load-more-btn more " rel="next">Load More</button></div></div></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="gossipcop-post-2" class="widget gossipcop-featured-widget"><div class="widget-wrap"><article class="post-185049 post type-post status-publish format-standard has-post-thumbnail category-celebrities tag-bethenny-frankel entry" aria-label="Bethenny Frankel Planning &#8216;$10 Million&#8217; Wedding?"> <div class="gc-featured-post">
<div class="gc-featured-content item-0">
<span class="story-cover-image"><a href="https://www.gossipcop.com/bethenny-frankel-planning-10-million-wedding/185049/" title="Bethenny Frankel Planning &#8216;$10 Million&#8217; Wedding?" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_1511535098-400x400.jpg" class="entry-image attachment-post" alt="Bethenny Frankel in a black dress" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_1511535098-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/04/shutterstock_1511535098-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Celebrities</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/bethenny-frankel-planning-10-million-wedding/185049/">Bethenny Frankel Planning &#8216;$10 Million&#8217; Wedding?</a></h2> </header>
</div>
</div>
</article><article class="post-185189 post type-post status-publish format-standard has-post-thumbnail category-news entry" aria-label="&#8216;Jeopardy!&#8217; Fans Revolt Against Guest Host Joe Buck, Call For Fan Favorite Instead"> <div class="gc-featured-post">
<div class="gc-featured-content item-1">
<span class="story-cover-image"><a href="https://www.gossipcop.com/jeopardy-fans-revolt-against-guest-host-joe-buck-call-for-fan-favorite-instead/185189/" title="&#8216;Jeopardy!&#8217; Fans Revolt Against Guest Host Joe Buck, Call For Fan Favorite Instead" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/04/joe-buck-jeopardy-complaints-400x400.jpg" class="entry-image attachment-post" alt="Joe Buck wears a dark suit at a FOX event" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/joe-buck-jeopardy-complaints-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/04/joe-buck-jeopardy-complaints-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">News</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/jeopardy-fans-revolt-against-guest-host-joe-buck-call-for-fan-favorite-instead/185189/">&#8216;Jeopardy!&#8217; Fans Revolt Against Guest Host Joe Buck, Call For Fan Favorite Instead</a></h2> </header>
</div>
</div>
</article><article class="post-184787 post type-post status-publish format-standard has-post-thumbnail category-celebrities entry" aria-label="Logan Paul vs. Jake Paul: Which YouTuber Has The Higher Net Worth?"> <div class="gc-featured-post">
<div class="gc-featured-content item-2">
 <span class="story-cover-image"><a href="https://www.gossipcop.com/logan-paul-vs-jake-paul-net-worth/184787/" title="Logan Paul vs. Jake Paul: Which YouTuber Has The Higher Net Worth?" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/04/Jake-and-Logan-Paul-400x400.jpg" class="entry-image attachment-post" alt="Logan Paul in a black hat and black shirt standing face-to-face with Jake Paul, who is wearing a white shirt and a pink hat." loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/Jake-and-Logan-Paul-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/04/Jake-and-Logan-Paul-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Celebrities</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/logan-paul-vs-jake-paul-net-worth/184787/">Logan Paul vs. Jake Paul: Which YouTuber Has The Higher Net Worth?</a></h2> </header>
</div>
</div>
</article><article class="post-185157 post type-post status-publish format-standard has-post-thumbnail category-news tag-pat-sajak entry" aria-label="Pat Sajak Suffers Embarrassing Gaffe On &#8216;Wheel Of Fortune&#8217;"> <div class="gc-featured-post">
<div class="gc-featured-content item-3">
<span class="story-cover-image"><a href="https://www.gossipcop.com/pat-sajak-suffers-embarrassing-gaffe-on-wheel-of-fortune/185157/" title="Pat Sajak Suffers Embarrassing Gaffe On &#8216;Wheel Of Fortune&#8217;" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/04/pat-sajak-wheel-gaffe-1-400x400.jpg" class="entry-image attachment-post" alt="A screenshot from an episode of Wheel Of Fortune" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/pat-sajak-wheel-gaffe-1-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/04/pat-sajak-wheel-gaffe-1-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">News</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/pat-sajak-suffers-embarrassing-gaffe-on-wheel-of-fortune/185157/">Pat Sajak Suffers Embarrassing Gaffe On &#8216;Wheel Of Fortune&#8217;</a></h2> </header>
</div>
</div>
</article><article class="post-185109 post type-post status-publish format-standard has-post-thumbnail category-news tag-american-idol entry" aria-label="Luke Bryan Beaten By Former &#8216;American Idol&#8217; Contestant; Lied About COVID Diagnosis To Hide It?"> <div class="gc-featured-post">
<div class="gc-featured-content item-4">
<span class="story-cover-image"><a href="https://www.gossipcop.com/luke-bryan-beaten-by-former-american-idol-contestant-lied-about-covid-diagnosis-to-hide-it/185109/" title="Luke Bryan Beaten By Former &#8216;American Idol&#8217; Contestant; Lied About COVID Diagnosis To Hide It?" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/04/luke-bryan-beaten-former-contestant-400x400.jpg" class="entry-image attachment-post" alt="Luke Bryan wears a blue suit as he walks the red carpet at the American Country Countdown Awards" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/luke-bryan-beaten-former-contestant-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/04/luke-bryan-beaten-former-contestant-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">News</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/luke-bryan-beaten-by-former-american-idol-contestant-lied-about-covid-diagnosis-to-hide-it/185109/">Luke Bryan Beaten By Former &#8216;American Idol&#8217; Contestant; Lied About COVID Diagnosis To Hide It?</a></h2> </header>
</div>
</div>
</article></div></section>
<div class="outbrain-widget" data-config="{&quot;title&quot;:&quot;SB_1&quot;,&quot;widget_id&quot;:&quot;SB_1&quot;,&quot;infinite_widget_id&quot;:&quot;&quot;,&quot;display_desktop&quot;:1,&quot;infinite&quot;:0,&quot;display_tablet&quot;:0,&quot;display_mobile&quot;:0,&quot;url&quot;:&quot;https:\/\/www.gossipcop.com\/james-charles-net-worth\/184871\/&quot;}"></div>
<section id="gossipcop-post-3" class="widget gossipcop-featured-widget"><div class="widget-wrap"><article class="post-185046 post type-post status-publish format-standard has-post-thumbnail category-celebrities tag-angelina-jolie entry" aria-label="Report: Angelina Jolie Dating Diplo"> <div class="gc-featured-post">
<div class="gc-featured-content item-0">
<span class="story-cover-image"><a href="https://www.gossipcop.com/report-angelina-jolie-dating-diplo/185046/" title="Report: Angelina Jolie Dating Diplo" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/04/ajdiplo-400x400.jpg" class="entry-image attachment-post" alt="Side-by-side photos of Angelina Jolie on the left and Diplo on the right" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/ajdiplo-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/04/ajdiplo-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Celebrities</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/report-angelina-jolie-dating-diplo/185046/">Report: Angelina Jolie Dating Diplo</a></h2> </header>
</div>
</div>
</article><article class="post-185005 post type-post status-publish format-standard has-post-thumbnail category-baby-buzz category-news tag-courteney-cox entry" aria-label="Courteney Cox Wants A Baby With Johnny McDaid?"> <div class="gc-featured-post">
<div class="gc-featured-content item-1">
<span class="story-cover-image"><a href="https://www.gossipcop.com/courteney-cox-wants-a-baby-with-johnny-mcdaid/185005/" title="Courteney Cox Wants A Baby With Johnny McDaid?" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/04/courteney-cox-johnny-mcdaid-baby-400x400.jpg" class="entry-image attachment-post" alt="Courteney Cox in all black in front of a blue background." loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/courteney-cox-johnny-mcdaid-baby-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/04/courteney-cox-johnny-mcdaid-baby-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Baby Buzz</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/courteney-cox-wants-a-baby-with-johnny-mcdaid/185005/">Courteney Cox Wants A Baby With Johnny McDaid?</a></h2> </header>
</div>
</div>
</article><article class="post-185069 post type-post status-publish format-standard has-post-thumbnail category-news tag-american-idol entry" aria-label="Former &#8216;American Idol&#8217; Contestant Charged With Second-Degree Felony"> <div class="gc-featured-post">
<div class="gc-featured-content item-2">
<span class="story-cover-image"><a href="https://www.gossipcop.com/former-american-idol-contestant-charged-with-second-degree-felony/185069/" title="Former &#8216;American Idol&#8217; Contestant Charged With Second-Degree Felony" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/04/cecil-ray-american-idol-arrested-400x400.jpg" class="entry-image attachment-post" alt="Cecil Ray wears a yellow shirt as he gives an interview on American Idol" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/cecil-ray-american-idol-arrested-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/04/cecil-ray-american-idol-arrested-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">News</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/former-american-idol-contestant-charged-with-second-degree-felony/185069/">Former &#8216;American Idol&#8217; Contestant Charged With Second-Degree Felony</a></h2> </header>
</div>
</div>
</article><article class="post-184811 post type-post status-publish format-standard has-post-thumbnail category-celebrities entry" aria-label="Galina Becker: What We Know About Roman Reigns And His Wife Of Five Children"> <div class="gc-featured-post">
<div class="gc-featured-content item-3">
<span class="story-cover-image"><a href="https://www.gossipcop.com/galina-becker-roman-reigns-wife/184811/" title="Galina Becker: What We Know About Roman Reigns And His Wife Of Five Children" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/04/Galina-Becker-Roman-Reigns-Wife-400x400.jpg" class="entry-image attachment-post" alt="Roman Reigns in a grey suit with a blue shirt and tie, standing with his wife, Galina Becker, who is wearing a black dress." loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/Galina-Becker-Roman-Reigns-Wife-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/04/Galina-Becker-Roman-Reigns-Wife-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Celebrities</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/galina-becker-roman-reigns-wife/184811/">Galina Becker: What We Know About Roman Reigns And His Wife Of Five Children</a></h2> </header>
</div>
</div>
</article><article class="post-184892 post type-post status-publish format-standard has-post-thumbnail category-celebrities tag-pete-davidson tag-saturday-night-live-snl entry" aria-label="Multiple Reports Claim Pete Davidson Is Feuding With ‘SNL’ Castmates"> <div class="gc-featured-post">
<div class="gc-featured-content item-4">
<span class="story-cover-image"><a href="https://www.gossipcop.com/multiple-reports-claim-pete-davidson-is-feuding-with-snl-castmates/184892/" title="Multiple Reports Claim Pete Davidson Is Feuding With ‘SNL’ Castmates" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/04/pete-davidson-hated-400x400.jpg" class="entry-image attachment-post" alt="Pete Davidson wearing sunglasses." loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/04/pete-davidson-hated-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/04/pete-davidson-hated-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Celebrities</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/multiple-reports-claim-pete-davidson-is-feuding-with-snl-castmates/184892/">Multiple Reports Claim Pete Davidson Is Feuding With ‘SNL’ Castmates</a></h2> </header>
</div>
</div>
</article></div></section>
</aside></div></div><footer class="site-footer"><div class="wrap"><a href="https://gossipcop.com"> <p class=footer-image></p></a><p></p><nav class="nav-secondary" aria-label="Secondary"><div class="wrap"><ul id="menu-footer-nav" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-159244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-159244"><a href="/"><span>© 2021 Gossip Cop Media</span></a></li>
<li id="menu-item-159242" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159242"><a href="https://www.gossipcop.com/about/"><span>About Us</span></a></li>
<li id="menu-item-159238" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159238"><a href="https://www.gossipcop.com/newsletter/"><span>Newsletter</span></a></li>
<li id="menu-item-159241" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159241"><a href="https://www.gossipcop.com/privacy/"><span>Privacy</span></a></li>
<li id="menu-item-159240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159240"><a href="https://www.gossipcop.com/terms/"><span>User Agreement</span></a></li>
<li id="menu-item-159239" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159239"><a href="https://www.gossipcop.com/contact/"><span>Contact</span></a></li>
<li id="menu-item-159243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-159243"><a href="/feed/"><span>RSS</span></a></li>
</ul></div></nav></div></footer> <div class="corpfooter">
<div class="contents">
<ul>
<li class="copyright"><span>&copy;Copyright 2021</span></li>
<li class="quilltlogo"><a href="https://www.quillt.com" target="_blank"><span class="logo"></span></a></li>
<li class="privacy">
<span>
For details on Quillt's privacy and cookie policies, please visit our
<a href="https://www.quillt.com/privacy-policy/" target="_blank">privacy policy</a>
page.
</span>
</li>
</ul>
<div id="choice-footer-msg" class="consent-ccpa-notice"></div>
</div>
</div>
</div> <div id="fb-root"></div>
<script>
    (function() {
        var enabled_integrations = {
            'params': {},
            'session': {},
            'scroll': {}
        };
        // Enable the prebid integration 1% of the time
        if ((Math.random() * 100) < 1) {
            enabled_integrations.prebid = {};
        }


        var pageparams = {"env":"production","content_id":184871,"site":"GC","page":"single","lmi":5,"s":"962d46df87","rid":"10d45297-0fe3-44d9-b597-5438869748e7","jigsaw_hash":"17680","full":"https:\/\/www.gossipcop.com\/james-charles-net-worth\/184871\/"};

        // Grab Clean Creative from setup_clean_creative
        pageparams.clcr = window._cc_included ? 1 : 0;

        (window._bsq = window._bsq || []).push(
            ['configure', {
                lifetime_parameters: {},
                session_parameters: {},
                page_parameters: pageparams,
                AWS_identity_pool_id: '3f9d4436-de0e-4ab4-a1a9-bb1fb8842252',
                AWS_region: 'us-east-1',
                stream: 'firehose-batsignal-GC',
                integrations: enabled_integrations
            }]
        );

        window._bsq.push(['send_event', 'page_view', {}]);

        let seen_ids = [];
        window.almUrlUpdate = function(permalink, type){
            let match = permalink.match(/\/(\d+)\/?(\?.*)?(#.*)?$/);
            if (match && match.length >= 2 && match[1]) {
                let pparams = {
                    'content_id': match[1],
                    'full': permalink,
                };
                window._bsq.push(['set_page_parameters', pparams, false, permalink]);
                if (seen_ids.indexOf(match[1]) < 0) {
                    window._bsq.push(['send_event', 'page_view', {}]);
                    seen_ids.push(match[1]);
                }
            }
        };
    })();
</script><script defer src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/batsignal/aws-sdk.2.190.0.min.js?ver=4f1a5556647321da9441' id='aws-sdk-js'></script>
<script id='batsignal-js-extra'>
var wp_domain = {"quillt":"wordpress"};
</script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/batsignal/batsignal_js.min.js?ver=39d9f96a10a7bfcdf6e4' id='batsignal-js'></script>
<script id='ajax-load-more-js-extra'>
var alm_localize = {"ajaxurl":"https:\/\/www.gossipcop.com\/wp\/wp-admin\/admin-ajax.php","alm_nonce":"041f428bc5","rest_api":"https:\/\/www.gossipcop.com\/wp-json\/","rest_nonce":"61ba17faf2","pluginurl":"https:\/\/www.gossipcop.com\/wp-content\/plugins\/ajax-load-more","speed":"200","ga_debug":"false","results_text":"Viewing {post_count} of {total_posts} results.","no_results_text":"No results found.","alm_debug":"","a11y_focus":"1"};
var ajax_load_more_vars = {"id":"ajax-load-more"};
</script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/ajax-load-more/core/dist/js/ajax-load-more.min.js?ver=5.4.2.1' id='ajax-load-more-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/inf_scroll.js?ver=1ec442bf23a1be3b318f' id='inf_scroll-js'></script>
<script defer src='https://www.gossipcop.com/wp/wp-includes/js/hoverIntent.min.js?ver=1.8.1' id='hoverIntent-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10' id='superfish-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.3.3' id='superfish-args-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.3.3' id='skip-links-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/outbrain.js?ver=d201f3e1c67279e4bbc3' id='quillt-outbrain-widget-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/social_login/general.js?ver=7.13.11' id='the_champ_ss_general_scripts-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/social_login/common.js?ver=7.13.11' id='the_champ_sl_common-js'></script>
<script id='thickbox-js-extra'>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.gossipcop.com\/wp\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script defer src='https://www.gossipcop.com/wp/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/facebook/sdk.js?ver=7.13.11' id='the_champ_fb_sdk-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/facebook/commenting.js?ver=7.13.11' id='the_champ_fb_commenting-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/sharing/sharing.js?ver=7.13.11' id='the_champ_share_counts-js'></script>
<script id='gossipcop-responsive-menu-js-extra'>
var genesis_responsive_menu = {"mainMenu":"","menuIconClass":"dashicons-before dashicons-menu","subMenu":"Submenu","subMenuIconClass":"dashicons-before dashicons-arrow-down-alt2","menuClasses":{"others":[".nav-primary"]}};
</script>
<script defer src='https://www.gossipcop.com/wp-content/themes/genesis/lib/js/menu/responsive-menus.min.js?ver=1.1.3' id='gossipcop-responsive-menu-js'></script>
<script src='https://www.gossipcop.com/wp-content/plugins/aawp/assets/dist/js/main.js?ver=3.15.1' id='aawp-js'></script>
<script defer src='https://www.gossipcop.com/wp/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>
</body></html>
