<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<script type="text/javascript">function theChampLoadEvent(e){var t=window.onload;if(typeof window.onload!="function"){window.onload=e}else{window.onload=function(){t();e()}}}</script>
<script type="text/javascript">var theChampDefaultLang = 'en_US', theChampCloseIconPath = 'https://www.gossipcop.com/wp-content/plugins/super-socializer/images/close.png';</script>
<script>var theChampSiteUrl = 'https://www.gossipcop.com', theChampVerified = 0, theChampEmailPopup = 0, heateorSsMoreSharePopupSearchText = 'Search';</script>
<script> var theChampLoadingImgPath = 'https://www.gossipcop.com/wp-content/plugins/super-socializer/images/ajax_loader.gif'; var theChampAjaxUrl = 'https://www.gossipcop.com/wp/wp-admin/admin-ajax.php'; var theChampRedirectionUrl = 'https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/'; var theChampRegRedirectionUrl = 'https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/'; </script>
<script> var theChampFBKey = '2914652698661364', theChampSameTabLogin = '0', theChampVerified = 0; var theChampAjaxUrl = 'https://www.gossipcop.com/wp/wp-admin/admin-ajax.php'; var theChampPopupTitle = ''; var theChampEmailPopup = 0; var theChampEmailAjaxUrl = 'https://www.gossipcop.com/wp/wp-admin/admin-ajax.php'; var theChampEmailPopupTitle = ''; var theChampEmailPopupErrorMsg = ''; var theChampEmailPopupUniqueId = ''; var theChampEmailPopupVerifyMessage = ''; var theChampSteamAuthUrl = ""; var theChampCurrentPageUrl = 'https%3A%2F%2Fwww.gossipcop.com%2Felton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms%2F2567137%2F';  var heateorMSEnabled = 0, theChampTwitterAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Twitter&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampLineAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Line&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampLiveAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Live&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampFacebookAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Facebook&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampYahooAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Yahoo&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampGoogleAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Google&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampVkontakteAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Vkontakte&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampLinkedinAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Linkedin&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampInstagramAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Instagram&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampWordpressAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Wordpress&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampDribbbleAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Dribbble&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampGithubAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Github&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampSpotifyAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Spotify&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampKakaoAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Kakao&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampTwitchAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Twitch&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampRedditAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Reddit&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampDisqusAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Disqus&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampDropboxAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Dropbox&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampFoursquareAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Foursquare&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampAmazonAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Amazon&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampStackoverflowAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Stackoverflow&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampDiscordAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Discord&super_socializer_redirect_to=" + theChampCurrentPageUrl, theChampMailruAuthUrl = theChampSiteUrl + "?SuperSocializerAuth=Mailru&super_socializer_redirect_to=" + theChampCurrentPageUrl;</script>
<script> var theChampFBKey = '2914652698661364', theChampFBLang = 'en_US', theChampFbLikeMycred = 0, theChampSsga = 0, theChampCommentNotification = 0, theChampHeateorFcmRecentComments = 0, theChampFbIosLogin = 0; </script>
<script type="text/javascript">var theChampFBCommentUrl = 'https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/'; var theChampFBCommentColor = ''; var theChampFBCommentNumPosts = ''; var theChampFBCommentWidth = '100%'; var theChampFBCommentOrderby = ''; var theChampCommentingTabs = "wordpress,facebook,disqus", theChampGpCommentsUrl = 'https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/', theChampDisqusShortname = '', theChampScEnabledTabs = 'wordpress,fb', theChampScLabel = 'Leave a reply', theChampScTabLabels = {"wordpress":"Default Comments (0)","fb":"Facebook Comments","disqus":"Disqus Comments"}, theChampGpCommentsWidth = 0, theChampCommentingId = 'respond'</script>
<script> var theChampSharingAjaxUrl = 'https://www.gossipcop.com/wp/wp-admin/admin-ajax.php', heateorSsFbMessengerAPI = 'https://www.facebook.com/dialog/send?app_id=2914652698661364&display=popup&link=%encoded_post_url%&redirect_uri=%encoded_post_url%',heateorSsWhatsappShareAPI = 'web', heateorSsUrlCountFetched = [], heateorSsSharesText = 'Shares', heateorSsShareText = 'Share', theChampPluginIconPath = 'https://www.gossipcop.com/wp-content/plugins/super-socializer/images/logo.png', theChampSaveSharesLocally = 0, theChampHorizontalSharingCountEnable = 0, theChampVerticalSharingCountEnable = 0, theChampSharingOffset = -10, theChampCounterOffset = -10, theChampMobileStickySharingEnabled = 0, heateorSsCopyLinkMessage = "Link copied.";
		var heateorSsVerticalSharingShortUrl = "https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/";		</script>
<style type="text/css">.the_champ_horizontal_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_horizontal_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_horizontal_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	.the_champ_vertical_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_vertical_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_vertical_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	@media screen and (max-width:783px){.the_champ_vertical_sharing{display:none!important}}</style>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta name="pushnami" content="wordpress-plugin" />
<link rel="manifest" href="/manifest.json">

<title>Elton John Puts Rapper On Blast, Has Twitter Users Up In Arms</title>
<meta name="description" content="One rapper in particular has been causing quite a bit of controversy for himself in the music industry. It’s one thing to upset the gay community, Dua" />
<link rel="canonical" href="https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Elton John Puts Rapper On Blast, Has Twitter Users Up In Arms" />
<meta property="og:description" content="One rapper in particular has been causing quite a bit of controversy for himself in the music industry. It’s one thing to upset the gay community, Dua" />
<meta property="og:url" content="https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/" />
<meta property="og:site_name" content="Gossip Cop" />
<meta property="article:publisher" content="https://www.facebook.com/GossipCop/" />
<meta property="article:published_time" content="2021-07-28T18:31:41+00:00" />
<meta property="article:modified_time" content="2021-07-28T18:31:51+00:00" />
<meta property="og:image" content="https://upload.gossipcop.com/gc/uploads/2021/07/elton-john-dababy-twitter.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="675" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@GossipCop" />
<meta name="twitter:site" content="@GossipCop" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Eric Gasa" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.gossipcop.com/#organization","name":"Gossip Cop","url":"https://www.gossipcop.com/","sameAs":["https://www.facebook.com/GossipCop/","https://www.instagram.com/gossipcop/","https://www.pinterest.com/gossipcop/","https://twitter.com/GossipCop"],"logo":{"@type":"ImageObject","@id":"https://www.gossipcop.com/#logo","inLanguage":"en-US","url":"https://upload.gossipcop.com/gc/uploads/2021/02/publisher-wordmark-black.png","contentUrl":"https://upload.gossipcop.com/gc/uploads/2021/02/publisher-wordmark-black.png","width":340,"height":54,"caption":"Gossip Cop"},"image":{"@id":"https://www.gossipcop.com/#logo"}},{"@type":"WebSite","@id":"https://www.gossipcop.com/#website","url":"https://www.gossipcop.com/","name":"Gossip Cop","description":"Honest Celebrity News &amp; Gossip","publisher":{"@id":"https://www.gossipcop.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.gossipcop.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/#primaryimage","inLanguage":"en-US","url":"https://upload.gossipcop.com/gc/uploads/2021/07/elton-john-dababy-twitter.jpg","contentUrl":"https://upload.gossipcop.com/gc/uploads/2021/07/elton-john-dababy-twitter.jpg","width":1200,"height":675,"caption":"(Drop of Light/Shutterstock.com)"},{"@type":"WebPage","@id":"https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/#webpage","url":"https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/","name":"Elton John Puts Rapper On Blast, Has Twitter Users Up In Arms","isPartOf":{"@id":"https://www.gossipcop.com/#website"},"primaryImageOfPage":{"@id":"https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/#primaryimage"},"datePublished":"2021-07-28T18:31:41+00:00","dateModified":"2021-07-28T18:31:51+00:00","description":"One rapper in particular has been causing quite a bit of controversy for himself in the music industry. It\u2019s one thing to upset the gay community, Dua","breadcrumb":{"@id":"https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/"]}]},{"@type":"BreadcrumbList","@id":"https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"News","item":"https://www.gossipcop.com/c/news/"},{"@type":"ListItem","position":2,"name":"Elton John Puts Rapper On Blast, Has Twitter Users Up In Arms"}]},{"@type":["Article","NewsArticle"],"@id":"https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/#article","isPartOf":{"@id":"https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/#webpage"},"author":{"@id":"https://www.gossipcop.com/#/schema/person/0eb1045520980b7b72e9c6d844ba5083"},"headline":"Elton John Puts Rapper On Blast, Has Twitter Users Up In Arms","datePublished":"2021-07-28T18:31:41+00:00","dateModified":"2021-07-28T18:31:51+00:00","mainEntityOfPage":{"@id":"https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/#webpage"},"wordCount":447,"publisher":{"@id":"https://www.gossipcop.com/#organization"},"image":{"@id":"https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/#primaryimage"},"thumbnailUrl":"https://upload.gossipcop.com/gc/uploads/2021/07/elton-john-dababy-twitter.jpg","keywords":["Elton John"],"articleSection":["Celebrities","News"],"inLanguage":"en-US","copyrightYear":"2021","copyrightHolder":{"@id":"https://www.gossipcop.com/#organization"}},{"@type":"Person","@id":"https://www.gossipcop.com/#/schema/person/0eb1045520980b7b72e9c6d844ba5083","name":"Eric Gasa","image":{"@type":"ImageObject","@id":"https://www.gossipcop.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/ecfd7a28d51c85763a7de9e81f05b9d4?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/ecfd7a28d51c85763a7de9e81f05b9d4?s=96&d=mm&r=g","caption":"Eric Gasa"},"url":"https://www.gossipcop.com/author/eric-gasa/"}]}</script>

<script>window.quillt={"consent":{"provider":"quantcast","country":"US","gdpr_applies":false,"ccpa_applies":null},"infinite_scroll":{"root_margin":"0px 0px -75% 0px"},"site":"GC","device":"desktop","content_id":2567137,"content_type":"post","lmi":5,"page":"single","categories":[{"id":2056,"name":"Celebrities","slug":"celebrities"},{"id":2057,"name":"News","slug":"news"}]};window.quillt.rand=Math.random();Object.freeze(window.quillt);</script>
<link rel='preconnect' href='https://www.googletagmanager.com' />
<link rel='preconnect' href='https://fonts.googleapis.com' />
<link rel='preconnect' href='https://upload.gossipcop.com' />
<link rel="alternate" type="application/rss+xml" title="Gossip Cop &raquo; Feed" href="https://www.gossipcop.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Gossip Cop &raquo; Comments Feed" href="https://www.gossipcop.com/comments/feed/" />
<link rel="preload" as="fetch" crossorigin href="https://apis.quantcast.mgr.consensu.org/geoip" /><link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='sponsored_article_banners-styles-css' href='https://www.gossipcop.com/wp-content/plugins/quillt/assets/sponsored_banner.css?ver=102eff003bec56b52eb0' media='all' />
<noscript><link rel='stylesheet' id='sponsored_article_banners-styles-css'  href='https://www.gossipcop.com/wp-content/plugins/quillt/assets/sponsored_banner.css?ver=102eff003bec56b52eb0' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='wp-block-library-css' href='https://www.gossipcop.com/wp/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' media='all' />
<noscript><link rel='stylesheet' id='wp-block-library-css'  href='https://www.gossipcop.com/wp/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='elasticpress-related-posts-block-css' href='https://www.gossipcop.com/wp-content/plugins/elasticpress/dist/css/related-posts-block-styles.min.css?ver=3.6.0' media='all' />
<noscript><link rel='stylesheet' id='elasticpress-related-posts-block-css'  href='https://www.gossipcop.com/wp-content/plugins/elasticpress/dist/css/related-posts-block-styles.min.css?ver=3.6.0' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='qc-choice-css' href='https://www.gossipcop.com/wp-content/plugins/quantcast-choice/public/css/style.min.css?ver=2.0.4' media='all' />
<noscript><link rel='stylesheet' id='qc-choice-css'  href='https://www.gossipcop.com/wp-content/plugins/quantcast-choice/public/css/style.min.css?ver=2.0.4' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='corporate-footer-css' href='https://www.gossipcop.com/wp-content/plugins/quillt/assets/corpfooter/corpfooter.css?ver=61a9aae84f495d5f9aae' media='all' />
<noscript><link rel='stylesheet' id='corporate-footer-css'  href='https://www.gossipcop.com/wp-content/plugins/quillt/assets/corpfooter/corpfooter.css?ver=61a9aae84f495d5f9aae' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='shutterstock-css' href='https://www.gossipcop.com/wp-content/plugins/shutterstock/public/css/shutterstock-public.css?ver=1.3.7' media='all' />
<noscript><link rel='stylesheet' id='shutterstock-css'  href='https://www.gossipcop.com/wp-content/plugins/shutterstock/public/css/shutterstock-public.css?ver=1.3.7' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='lasso-live-css' href='https://www.gossipcop.com/wp-content/plugins/lasso/admin/assets/css/lasso-live.css?v=1627409830&#038;ver=262' media='all' />
<noscript><link rel='stylesheet' id='lasso-live-css'  href='https://www.gossipcop.com/wp-content/plugins/lasso/admin/assets/css/lasso-live.css?v=1627409830&#038;ver=262' media='all' />
</noscript>
<link rel='stylesheet' id='gossipcop-css' href='https://www.gossipcop.com/wp-content/themes/gossipcop/css/style.css?ver=11671c7240a83485e39b' media='all' />
<style id="gossipcop-fonts-css" media="all">@font-face {
  font-family: 'Playfair Display';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/playfairdisplay/v22/nuFvD-vYSZviVYUb_rj3ij__anPXJzDwcbmjWBN2PKdFvUDQ.ttf) format('truetype');
}
@font-face {
  font-family: 'Playfair Display';
  font-style: normal;
  font-weight: 500;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/playfairdisplay/v22/nuFvD-vYSZviVYUb_rj3ij__anPXJzDwcbmjWBN2PKd3vUDQ.ttf) format('truetype');
}
@font-face {
  font-family: 'Playfair Display';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/playfairdisplay/v22/nuFvD-vYSZviVYUb_rj3ij__anPXJzDwcbmjWBN2PKeiukDQ.ttf) format('truetype');
}
@font-face {
  font-family: 'Playfair Display';
  font-style: normal;
  font-weight: 900;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/playfairdisplay/v22/nuFvD-vYSZviVYUb_rj3ij__anPXJzDwcbmjWBN2PKfsukDQ.ttf) format('truetype');
}
</style>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='dashicons-css' href='https://www.gossipcop.com/wp/wp-includes/css/dashicons.min.css?ver=5.7.2' media='all' />
<noscript><link rel='stylesheet' id='dashicons-css'  href='https://www.gossipcop.com/wp/wp-includes/css/dashicons.min.css?ver=5.7.2' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='thickbox-css' href='https://www.gossipcop.com/wp/wp-includes/js/thickbox/thickbox.css?ver=5.7.2' media='all' />
<noscript><link rel='stylesheet' id='thickbox-css'  href='https://www.gossipcop.com/wp/wp-includes/js/thickbox/thickbox.css?ver=5.7.2' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='the_champ_frontend_css-css' href='https://www.gossipcop.com/wp-content/plugins/super-socializer/css/front.css?ver=7.13.21' media='all' />
<noscript><link rel='stylesheet' id='the_champ_frontend_css-css'  href='https://www.gossipcop.com/wp-content/plugins/super-socializer/css/front.css?ver=7.13.21' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='the_champ_sharing_default_svg-css' href='https://www.gossipcop.com/wp-content/plugins/super-socializer/css/share-svg.css?ver=7.13.21' media='all' />
<noscript><link rel='stylesheet' id='the_champ_sharing_default_svg-css'  href='https://www.gossipcop.com/wp-content/plugins/super-socializer/css/share-svg.css?ver=7.13.21' media='all' />
</noscript>
<link rel="preload" as="style" onload="this.onload=null;this.rel='stylesheet'" id='aawp-css' href='https://www.gossipcop.com/wp-content/plugins/aawp/assets/dist/css/main.css?ver=3.15.2' media='all' />
<noscript><link rel='stylesheet' id='aawp-css'  href='https://www.gossipcop.com/wp-content/plugins/aawp/assets/dist/css/main.css?ver=3.15.2' media='all' />
</noscript>
<link rel="preload" href="https://upload.gossipcop.com/gc/uploads/2021/07/elton-john-dababy-twitter-702x526.jpg" as="image">
<script id='pushnami_script-js-after'>
(function(document, window){
    var script = document.createElement("script");
    script.type = "text/javascript";
    script.src = "https://api.pushnami.com/scripts/v1/pushnami-adv/604698f863b0b2001034e9e0";
    script.onload = function() {
        Pushnami
            .update({"last_category":"Celebrities"})
            .prompt({"delay":15000});
    };
    document.getElementsByTagName("head")[0].appendChild(script);
})(document, window);
</script>
<script id='qc-choice-js-extra'>
var choice_cmp_config = {"utid":"A9b8GRq-NyEYK","enabled":"all","ccpa":"manual","datalayer":"true"};
</script>
<script async="async" src='https://www.gossipcop.com/wp-content/plugins/quantcast-choice/public/js/script.min.js?ver=2.0.4' id='qc-choice-js'></script>
<script src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/consent/consentwrapper.js?ver=c4959fe8cea998f8a7ad' id='consentwrapper-js'></script>
<script src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/consent/consentwrapper_init.js?ver=4196640f776e7d91f584' id='consentwrapper_init-js'></script>
<script src='https://www.gossipcop.com/wp/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script src='https://www.gossipcop.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script id='jquery-js-after'>
window.$ = window.jQuery;
</script>
<script src='https://www.gossipcop.com/wp-content/plugins/shutterstock/public/js/shutterstock-public.js?ver=1.3.7' id='shutterstock-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/themes/gossipcop/js/theme.js?ver=9cdb1e546d0e98b6f37a' id='gossipcop-js'></script>
<script src='https://www.googletagmanager.com/gtag/js?id=UA-45900089-1' id='google_gtagjs-js' async></script>
<script id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
                    (function (i, r) {
                        i["GoogleAnalyticsObject"] = r;
                        (i[r] = i[r] || function () {(i[r].q = i[r].q || []).push(arguments);});
                        (i[r].l = 1 * new Date());
                    })(window,"ga");
                    ga(function(){
                        // delay this to allow the tracker to be setup first
                        setTimeout(function(){
                            var tracker = ga.getAll().pop();
                            tracker && tracker.set('customTask', function(model){
                                if (model.get('hitType') === 'timing') {
                                    model.set({"dimension1":5,"dimension3":2567137});
                                }
                            });
                        }, 0);
                    });
gtag('set', 'linker', {"domains":["www.gossipcop.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-45900089-1", {"anonymize_ip":true,"dimension1":5,"dimension3":2567137});
</script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.gossipcop.com/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.gossipcop.com/wp/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.7.2" />
<style type="text/css">.aawp .aawp-tb__row--highlight{background-color:#256aaf;}.aawp .aawp-tb__row--highlight{color:#256aaf;}.aawp .aawp-tb__row--highlight a{color:#256aaf;}</style><meta name="generator" content="Site Kit by Google 1.36.0" /><link rel=preload as=fetch crossorigin href='/api/info/'><style type="text/css">
			:root{
				--lasso-main: black !important;
				--lasso-title: black !important;
				--lasso-button: black !important;
				--lasso-secondary-button: #22BAA0 !important;
				--lasso-button-text: white !important;
				--lasso-background: white !important;
				--lasso-pros: #22BAA0 !important;
				--lasso-cons: #E06470 !important;
			}
			
			
		</style>
<script type="text/javascript">
				// Notice how this gets configured before we load Font Awesome
				window.FontAwesomeConfig = { autoReplaceSvg: false }
			</script>
<script id="google-funding-choices">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</script><link rel="amphtml" href="https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/?amp">
<script>
( function( w, d, s, l, i ) {
	w[l] = w[l] || [];
	w[l].push( {'gtm.start': new Date().getTime(), event: 'gtm.js'} );
	var f = d.getElementsByTagName( s )[0],
		j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
	j.async = true;
	j.src = 'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
	f.parentNode.insertBefore( j, f );
} )( window, document, 'script', 'dataLayer', 'GTM-NNJMT3R' );
</script>

<style>
</style>
<link rel="icon" href="https://upload.gossipcop.com/gc/uploads/2021/01/gc_favicon_16.png" sizes="32x32" />
<link rel="icon" href="https://upload.gossipcop.com/gc/uploads/2021/01/gc_favicon_16.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://upload.gossipcop.com/gc/uploads/2021/01/gc_favicon_16.png" />
<meta name="msapplication-TileImage" content="https://upload.gossipcop.com/gc/uploads/2021/01/gc_favicon_16.png" />
<link rel="preload" href="/wp-content/plugins/quantcast-choice/public/js/script.min.js?ver=2.0.4" as="script"><link rel="preload" href="/wp-content/plugins/quillt/assets/consent/consentwrapper.js?ver=c4959fe8cea998f8a7ad" as="script"><link rel="preload" href="/wp-content/plugins/quillt/assets/consent/consentwrapper_init.js?ver=4196640f776e7d91f584" as="script"><link rel="preload" href="/wp/wp-includes/js/jquery/jquery.min.js?ver=3.5.1" as="script"><link rel="preload" href="/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2" as="script"><link rel="preload" href="/wp-content/plugins/shutterstock/public/js/shutterstock-public.js?ver=1.3.7" as="script"><link rel="preload" href="/wp-content/themes/gossipcop/js/theme.js?ver=9cdb1e546d0e98b6f37a" as="script"><link rel="preload" href="/wp-content/plugins/quillt/assets/sponsored_banner.css?ver=102eff003bec56b52eb0" as="style"><link rel="preload" href="/wp/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2" as="style"><link rel="preload" href="/wp-content/plugins/elasticpress/dist/css/related-posts-block-styles.min.css?ver=3.6.0" as="style"><link rel="preload" href="/wp-content/plugins/quantcast-choice/public/css/style.min.css?ver=2.0.4" as="style"><link rel="preload" href="/wp-content/plugins/quillt/assets/corpfooter/corpfooter.css?ver=61a9aae84f495d5f9aae" as="style"><link rel="preload" href="/wp-content/plugins/shutterstock/public/css/shutterstock-public.css?ver=1.3.7" as="style"><link rel="preload" href="/wp-content/plugins/lasso/admin/assets/css/lasso-live.css?v=1627409830&#038;ver=262" as="style"><link rel="preload" href="/wp-content/themes/gossipcop/css/style.css?ver=11671c7240a83485e39b" as="style"><link rel="preload" href="/wp/wp-includes/css/dashicons.min.css?ver=5.7.2" as="style"><link rel="preload" href="/wp/wp-includes/js/thickbox/thickbox.css?ver=5.7.2" as="style"><link rel="preload" href="/wp-content/plugins/super-socializer/css/front.css?ver=7.13.21" as="style"><link rel="preload" href="/wp-content/plugins/super-socializer/css/share-svg.css?ver=7.13.21" as="style"><link rel="preload" href="/wp-content/plugins/aawp/assets/dist/css/main.css?ver=3.15.2" as="style"> <style id="wp-custom-css">
			@media (min-width: 0px) {
    .ad_inline.ad--prebid-bidder-vidazoo .ad_slot_target {
        position: relative;
        top: 0;
        bottom: 0;
    }
}		</style>
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/quillt/assets/filter_links_new_tab.js?ver=d2227f300529686f76f8" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/quillt/assets/ads-prebid.js?ver=f6e2186486eb52f45ccb" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/quillt/assets/batsignal/aws-sdk.2.190.0.min.js?ver=4f1a5556647321da9441" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/quillt/assets/batsignal/batsignal_js.min.js?ver=a13fdf9b90273cfc718a" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/quillt/assets/inf_scroll.js?ver=3606da7efd9131093594" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.3.3" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.3.3" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/social_login/general.js?ver=7.13.21" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/social_login/common.js?ver=7.13.21" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/facebook/sdk.js?ver=7.13.21" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/facebook/commenting.js?ver=7.13.21" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/sharing/sharing.js?ver=7.13.21" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/quillt/assets/outbrain.js?ver=437ed88dcfcaef96260a" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/themes/genesis/lib/js/menu/responsive-menus.min.js?ver=1.1.3" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/quillt/assets/google_analytics.js?ver=0dcdf4496ba7f66a8715" />
<link rel="preload" as="script" href="https://www.gossipcop.com/wp-content/plugins/aawp/assets/dist/js/main.js?ver=3.15.2" />
</head>
<body class="post-template-default single single-post postid-2567137 single-format-standard wp-embed-responsive aawp-custom header-full-width content-sidebar genesis-breadcrumbs-hidden genesis-singular-image-visible genesis-footer-widgets-hidden first-block-core-paragraph"> 
<noscript>
			<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NNJMT3R" height="0" width="0" style="display:none;visibility:hidden"></iframe>
		</noscript>

<div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://www.gossipcop.com/">Gossip Cop</a></p><p class="site-description">Honest Celebrity News &amp; Gossip</p></div><nav class="nav-primary genesis-responsive-menu" aria-label="Main" id="genesis-nav-primary"><div class="wrap"><ul id="menu-header-nav" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-159223" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-159223"><a href="https://www.gossipcop.com/c/news/"><span>News <div class="mobile-only category-extras"> <span class="description mobile-only"> The latest in celebrity gossip </span> <img class="image mobile-only" loading="lazy" src="https://upload.gossipcop.com/gc/uploads/2021/01/news.jpg" /></div></span></a></li>
<li id="menu-item-159224" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-159224"><a href="https://www.gossipcop.com/c/entertainment/"><span>Entertainment <div class="mobile-only category-extras"> <span class="description mobile-only"> Hollywood and beyond </span> <img class="image mobile-only" loading="lazy" src="https://upload.gossipcop.com/gc/uploads/2021/01/entertainment.jpg" /></div></span></a></li>
<li id="menu-item-159222" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-159222"><a href="https://www.gossipcop.com/c/celebrities/"><span>Celebrities <div class="mobile-only category-extras"> <span class="description mobile-only"> Your favorite stars from A to Z </span> <img class="image mobile-only" loading="lazy" src="https://upload.gossipcop.com/gc/uploads/2021/01/celebrities.jpg" /></div></span></a></li>
<li id="menu-item-159225" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-159225"><a href="https://www.gossipcop.com/c/royals/"><span>Royal Family <div class="mobile-only category-extras"> <span class="description mobile-only"> Latest news from the House Of Windsor </span> <img class="image mobile-only" loading="lazy" src="https://upload.gossipcop.com/gc/uploads/2021/01/royal.jpg" /></div></span></a></li>
<li id="menu-item-186621" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-186621"><a href="https://www.gossipcop.com/c/lifestyle/"><span>Lifestyle <div class="mobile-only category-extras"> <span class="description mobile-only"> Everything style, beauty, food, and more </span> <img class="image mobile-only" loading="lazy" src="https://upload.gossipcop.com/gc/uploads/2021/04/lifestyle-2.jpg" /></div></span></a></li>
<li class="primary-extras menu-item"><div class="header-search"><div id="primary-search-container" class="search-container"><form class="search-form" method="get" action="https://www.gossipcop.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-1">search</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="search"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.gossipcop.com/?s={s}"></form> <button type="button" class="header-search-button" id="toggleSearchForm"></button> </div></div> <div class="header-subscribe"><a href="https://www.gossipcop.com/newsletter/" id="subscribe-link"><span>Subscribe</span></a></div></li><li class="social-icons menu-item"><div class="share-heading">FOLLOW US</div><ul class="social-block"><li class="facebook"><a target="_blank" href="https://www.facebook.com/GossipCop/"></a></li> <li class="twitter"><a target="_blank" href="https://twitter.com/GossipCop" data-show-count="false" data-show-screen-name="false"></a></li> <li class="pinterest"><a target="_blank" href="https://www.pinterest.com/gossipcop/"></a></li> <li class="instagram"><a target="_blank" href="https://www.instagram.com/gossipcop/"></a></li> <li class="flipboard"><a data-flip-widget="ico" href="https://flipboard.com/@GossipCop?utm_campaign=tools&utm_medium=follow&action=follow&utm_source=www.gossipcop.com" target="_blank"></a><script defer src="https://cdn.flipboard.com/web/buttons/js/flbuttons.min.js"></script></li></ul></li></ul></div></nav><div class="mobile header-search"><div id="mobile-search-container" class="search-container"><form class="search-form" method="get" action="https://www.gossipcop.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-2">search</label><input class="search-form-input" type="search" name="s" id="searchform-2" placeholder="search"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.gossipcop.com/?s={s}"></form> <button type="button" class="header-search-button" id="toggleMobileSearchForm"></button> </div> </div></div></header><div class='content-related-block related-carousel'>
<div class='post-related'>
<a class="post-related-post post-2567194 post type-post status-publish format-standard has-post-thumbnail category-news tag-alex-rodriguez tag-ben-affleck tag-jennifer-lopez entry" id="post-2567194" href='https://www.gossipcop.com/alex-rodriguez-bizarrely-copies-ex-jennifer-lopez-ben-affleck-during-birthday-trip-with-nfl-reporter/2567194/'>
<div class='post-related-content'>
<span class='post-related-image'>
<img width="150" height="84" src="https://upload.gossipcop.com/gc/uploads/2021/07/alex-rodriguez-twinning-birthdays-lopez-150x84.jpg" class="attachment-thumbnail-scaled size-thumbnail-scaled" alt="Alex Rodriguez holds up his phone to take a photo of an out of frame Jennifer Lopez on the red carpet" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/alex-rodriguez-twinning-birthdays-lopez-150x84.jpg 150w, https://upload.gossipcop.com/gc/uploads/2021/07/alex-rodriguez-twinning-birthdays-lopez-300x169.jpg 300w, https://upload.gossipcop.com/gc/uploads/2021/07/alex-rodriguez-twinning-birthdays-lopez-1024x576.jpg 1024w, https://upload.gossipcop.com/gc/uploads/2021/07/alex-rodriguez-twinning-birthdays-lopez-768x432.jpg 768w, https://upload.gossipcop.com/gc/uploads/2021/07/alex-rodriguez-twinning-birthdays-lopez.jpg 1200w" sizes="(max-width: 150px) 100vw, 150px" /> </span>
<span class='post-related-category'>
News </span>
<span class='post-related-title'>
Alex Rodriguez Bizarrely Copies Ex Jennifer Lopez, Ben Affleck During Birthday Trip With NFL Reporter </span>
<span class='post-related-summary'>
<p>Alex Rodriguez recently celebrated his birthday, and strangely, it was almost exactly the same way his ex Jennifer Lopez celebrated just days earlier. In fact, there were so many overlaps between the exes’ outings that Rodriguez wound up visiting the same shops Lopez and her new beau Ben Affleck had just a few hours apart. [&hellip;]</p> </span>
<span class='post-related-author'>
by Brianna Morton </span>
</div>
</a>
<a class="post-related-post post-2567200 post type-post status-publish format-standard has-post-thumbnail category-news tag-kelly-clarkson tag-reba-mcentire entry" id="post-2567200" href='https://www.gossipcop.com/brandon-blackstocks-divorce-from-kelly-clarkson-eerily-mirrors-his-dads-split-from-reba-mcentire/2567200/'>
<div class='post-related-content'>
<span class='post-related-image'>
<img width="150" height="84" src="https://upload.gossipcop.com/gc/uploads/2021/07/brandon-blackstock-kelly-clarkson-divorce-similarities-150x84.jpg" class="attachment-thumbnail-scaled size-thumbnail-scaled" alt="" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/brandon-blackstock-kelly-clarkson-divorce-similarities-150x84.jpg 150w, https://upload.gossipcop.com/gc/uploads/2021/07/brandon-blackstock-kelly-clarkson-divorce-similarities-300x169.jpg 300w, https://upload.gossipcop.com/gc/uploads/2021/07/brandon-blackstock-kelly-clarkson-divorce-similarities-1024x576.jpg 1024w, https://upload.gossipcop.com/gc/uploads/2021/07/brandon-blackstock-kelly-clarkson-divorce-similarities-768x432.jpg 768w, https://upload.gossipcop.com/gc/uploads/2021/07/brandon-blackstock-kelly-clarkson-divorce-similarities.jpg 1200w" sizes="(max-width: 150px) 100vw, 150px" /> </span>
<span class='post-related-category'>
News </span>
<span class='post-related-title'>
Brandon Blackstock&#8217;s Divorce From Kelly Clarkson Eerily Mirrors His Dad’s Split From Reba McEntire </span>
<span class='post-related-summary'>
<p>Divorce certainly pays alright. Recently divorced singer Kelly Clarkson must fork over some hefty spousal support to ex-husband Brandon Blackstock to the tune of about $250,000 per month. And if you thought that figure was steep, wait until you hear Blackstock’s original demand for $436,000. So really, not an entirely bad deal for Clarkson but [&hellip;]</p> </span>
<span class='post-related-author'>
by Eric Gasa </span>
</div>
</a>
<a class="post-related-post post-2566756 post type-post status-publish format-standard has-post-thumbnail category-celebrities entry" id="post-2566756" href='https://www.gossipcop.com/report-donny-and-marie-osmond-bury-the-hatchet-after-years-long-rift/2566756/'>
<div class='post-related-content'>
<span class='post-related-image'>
<img width="150" height="100" src="https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1179086737-150x100.jpg" class="attachment-thumbnail-scaled size-thumbnail-scaled" alt="Donny Osmond in a black suit with Marie Osmond in a yellow dress" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1179086737-150x100.jpg 150w, https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1179086737-300x200.jpg 300w, https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1179086737-1024x683.jpg 1024w, https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1179086737-768x512.jpg 768w, https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1179086737.jpg 1200w" sizes="(max-width: 150px) 100vw, 150px" /> </span>
<span class='post-related-category'>
Celebrities </span>
<span class='post-related-title'>
Report: Donny And Marie Osmond ‘Bury The Hatchet’ After Years-Long ‘Rift’ </span>
<span class='post-related-summary'>
<p>Are Donny and Marie Osmond finally making up to go back on tour together? Were they even fighting in the first place? One tabloid seemed to think so and wrote in their latest issue about burying the “hatchet.” Gossip Cop investigates.&nbsp; The Osmonds&#8217; Sibling Rivalry Is Over? The Globe purports that the Osmonds are getting [&hellip;]</p> </span>
<span class='post-related-author'>
by Cortland Ann </span>
</div>
</a>
<a class="post-related-post post-2566436 post type-post status-publish format-standard has-post-thumbnail category-celebrities tag-pete-davidson tag-verified-content entry" id="post-2566436" href='https://www.gossipcop.com/pete-davidson-leaving-snl-moving-to-london-full-time-to-be-with-girlfriend-phoebe-dynevor/2566436/'>
<div class='post-related-content'>
<span class='post-related-image'>
<img width="150" height="100" src="https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1205388760-150x100.jpg" class="attachment-thumbnail-scaled size-thumbnail-scaled" alt="Pete Davidson in a black shirt" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1205388760-150x100.jpg 150w, https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1205388760-300x201.jpg 300w, https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1205388760-1024x684.jpg 1024w, https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1205388760-768x513.jpg 768w, https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1205388760.jpg 1200w" sizes="(max-width: 150px) 100vw, 150px" /> </span>
<span class='post-related-category'>
Celebrities </span>
<span class='post-related-title'>
Pete Davidson Leaving ‘SNL,’ Moving To London ‘Full-Time’ To Be With Girlfriend Phoebe Dynevor? </span>
<span class='post-related-summary'>
<p>Saturday Night Live’s Pete Davidson and Bridgerton’s Phoebe Dynevor were first linked together earlier this year. Now, one tabloid is saying the comedian is ready to leave Staten Island and the rest of the country behind to move to London to be with Dynevor. Gossip Cop investigates.  Moving To London To Be WIth Dynevor? According [&hellip;]</p> </span>
<span class='post-related-author'>
by Cortland Ann </span>
</div>
</a>
</div></div><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><div class="category-breadcrumb"><a href=https://www.gossipcop.com/c/celebrities/ class="category-breadcrumb">Celebrities</a></div><article class="post-2567137 post type-post status-publish format-standard has-post-thumbnail category-celebrities category-news tag-elton-john entry" aria-label="Elton John Puts Rapper On Blast, Has Twitter Users Up In Arms"><header class="entry-header"><h1 class="entry-title">Elton John Puts Rapper On Blast, Has Twitter Users Up In Arms</h1>
</header><div class="entry-content"><div class="author-byline"><div class="initial-bubbles"><span class="initial-box">E</span></div><a class="right-byline" href="https://www.gossipcop.com/about"><div class="authors"><span class="name">Eric Gasa</span></div><div class="published-date">1:31 pm, July 28, 2021</div></a></div><figure class="cover-image"><img width="702" height="526" src="https://upload.gossipcop.com/gc/uploads/2021/07/elton-john-dababy-twitter-702x526.jpg" class="singular-image entry-image" alt="" loading="lazy" /><figcaption class="image-attribution">(Drop of Light/Shutterstock.com)</figcaption></figure><div style='clear: both'></div><div class='the_champ_sharing_container the_champ_horizontal_sharing' super-socializer-data-href="https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/"><div class='the_champ_sharing_title' style="font-weight:bold"></div><ul class="the_champ_sharing_ul"><li class="theChampSharingRound"><i style="width:35px;height:35px;" alt="Facebook" Title="Facebook" class="theChampSharing theChampFacebookBackground" onclick='theChampPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.gossipcop.com%2Felton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms%2F2567137%2F")'><ss style="display:block;" class="theChampSharingSvg theChampFacebookSvg"></ss></i></li><li class="theChampSharingRound"><i style="width:35px;height:35px;" alt="Twitter" Title="Twitter" class="theChampSharing theChampTwitterBackground" onclick='theChampPopup("http://twitter.com/intent/tweet?text=Elton%20John%20Puts%20Rapper%20On%20Blast%2C%20Has%20Twitter%20Users%20Up%20In%20Arms&url=https%3A%2F%2Fwww.gossipcop.com%2Felton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms%2F2567137%2F")'><ss style="display:block;" class="theChampSharingSvg theChampTwitterSvg"></ss></i></li><li class="theChampSharingRound"><i style="width:35px;height:35px;" alt="Flipboard" Title="Flipboard" class="theChampSharing theChampFlipboardBackground" onclick='theChampPopup("https://share.flipboard.com/bookmarklet/popout?v=2&url=https%3A%2F%2Fwww.gossipcop.com%2Felton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms%2F2567137%2F&title=Elton%20John%20Puts%20Rapper%20On%20Blast%2C%20Has%20Twitter%20Users%20Up%20In%20Arms")'><ss style="display:block;" class="theChampSharingSvg theChampFlipboardSvg"></ss></i></li><li class="theChampSharingRound"><i style="width:35px;height:35px;" alt="Pinterest" Title="Pinterest" class="theChampSharing theChampPinterestBackground" onclick="javascript:void((function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());"><ss style="display:block;" class="theChampSharingSvg theChampPinterestSvg"></ss></i></li><li class="theChampSharingRound"><i style="width:35px;height:35px;" alt="Instagram" Title="Instagram" class="theChampSharing theChampInstagramBackground"><a href="https://www.instagram.com/gossipcop" target="_blank"><ss style="display:block;" class="theChampSharingSvg theChampInstagramSvg"></ss></a></i></li><li class="theChampSharingRound"><i style="width:35px;height:35px;" alt="Email" Title="Email" class="theChampSharing theChampEmailBackground" onclick="window.open('mailto:?subject=' + decodeURIComponent('Elton%20John%20Puts%20Rapper%20On%20Blast%2C%20Has%20Twitter%20Users%20Up%20In%20Arms' ).replace('&', '%26') + '&body=' + decodeURIComponent('https%3A%2F%2Fwww.gossipcop.com%2Felton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms%2F2567137%2F' ), '_blank')"><ss style="display:block" class="theChampSharingSvg theChampEmailSvg"></ss></i></li></ul><div style="clear:both"></div></div><div style='clear: both'></div><div class="entry-content-inner">
<p>One rapper in particular has been causing quite a bit of controversy for himself in the music industry. It’s one thing to upset the gay community, <strong>Dua Lipa</strong>, and even <strong>Megan Thee Stallion</strong> in one fell swoop, but you definitely know that you’ve done <a data-lasso-id="87141" href="https://www.gossipcop.com/twitter-divided-after-dababy-refuses-to-pay-200-to-kids-selling-candy/207074/" target="_blank" rel="noopener">something wrong</a> when Sir <strong>Elton John</strong> gets involved!</p>
<h2 id="h-digging-the-hole-deeper">Digging The Hole Deeper</h2>
<p>The artist in question is Cleveland MC DaBaby and he’s certainly not making his PR team’s job any easier after going on a homophobic rant at last week’s Rolling Loud Festival in Miami.</p>
<p>As one may expect, the blowback has been swift and justifiable. Somehow the rapper even managed to make things worse with an ill-fated apology on Monday when he reiterated even more homophobic rhetoric. One thing DaBaby said that got people especially upset was his outdated and incorrect views on HIV. This shot specifically is what got <a data-lasso-id="87142" href="https://www.gossipcop.com/report-supersized-elton-john-at-risk-for-heart-attack-after-yo-yo-dieting/203455/" target="_blank" rel="noopener">the great Sir Elton John</a> involved and Twitter is certainly taking sides.</p>
<h2 id="h-a-legend-speaks">A Legend Speaks</h2>
<p>John, who has not only been an advocate for HIV research for years but actually runs a foundation in his name for the cause, posted on Twitter Wednesday not only voicing his displeasure but dispelling many myths about the deadly disease. </p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">(1/5) We&#39;ve been shocked to read about the HIV misinformation and homophobic statements made at a recent DaBaby show. This fuels stigma and discrimination and is the opposite of what our world needs to fight the AIDS epidemic.<br> <br>The facts are: <a href="https://t.co/MqCv3vWiz2">pic.twitter.com/MqCv3vWiz2</a></p>&mdash; Elton John (@eltonofficial) <a href="https://twitter.com/eltonofficial/status/1420383595202494469?ref_src=twsrc%5Etfw">July 28, 2021</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>The Grammy-award-winning artist dropped some sobering truths in the five comment thread, especially about the harsh stigma gay black men face regarding HIV and AIDS. It’s also worth noting John’s firsthand experience with the disease in the 1980s after losing his good friend Freddie Mercury. Being Twitter, people are certainly taking sides and even suggesting that the <a data-lasso-id="87143" href="https://www.gossipcop.com/elton-john-making-rocketman-sequel-about-his-feud-with-madonna/201305/" target="_blank" rel="noopener">“Rocket Man” singer</a> may have just canceled DaBaby for good.</p>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Now, if Elton John coming for you … yeah, DaBaby is DaDone. <br><br>Fumbled your own bag! Ine feel sorry for you though. Pack it up! <a href="https://t.co/kWRkKjjj0c">pic.twitter.com/kWRkKjjj0c</a></p>&mdash; Hermes ☿ (They/Them) (@thehermeister) <a href="https://twitter.com/thehermeister/status/1420398440178139137?ref_src=twsrc%5Etfw">July 28, 2021</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">The Arch Bishop of White Music Elton John said <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="80c4c0e2">[email&#160;protected]</a>äby is cancelled… it’s above us now. <a href="https://t.co/Rce29g6n6m">pic.twitter.com/Rce29g6n6m</a></p>&mdash; Yeet the Rich (@Chartheegreat) <a href="https://twitter.com/Chartheegreat/status/1420402069425508356?ref_src=twsrc%5Etfw">July 28, 2021</a></blockquote><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">WHEWWWWWW YOU KNOW YOU FUCKED UP WHEN ELTON JOHN HAS A COMMENT 💀 <a href="https://t.co/s2TO0GIOqM">https://t.co/s2TO0GIOqM</a></p>&mdash; Quite literally&#8230; (@WYETTHASSP0KEN) <a href="https://twitter.com/WYETTHASSP0KEN/status/1420398978810646533?ref_src=twsrc%5Etfw">July 28, 2021</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>This however hasn’t been the first time that the rapper has made <a href="https://www.gossipcop.com/dababy-questioned-by-police-following-shooting-controversial-rapper-boosie-badazz-involved-in-separate-deadly-shoot-out/192291/" target="_blank" rel="noopener" data-lasso-id="87144">questionable headlines</a>, but whether folks give him the boot for good has yet to be seen. Regardless, we can’t help but applaud John for setting the record straight; not only for speaking out against homophobia but spreading AIDS awareness.&nbsp;</p>
<p>The glam-rock legend certainly said it best in his last tweet: “We must spread compassion and love for the most marginalized people in our communities. A musician’s job is to bring people together.” That&#8217;s absolutely a message we can get behind. </p>
<h2 id="h-more-news-from-gossip-cop">More News From Gossip Cop</h2>
<p><a data-lasso-id="87145" href="https://www.gossipcop.com/dababys-surprising-height---how-tall-is-dababy/2559006?utm_source=ref_app_link" target="_blank" rel="noopener">How Tall Is DaBaby? All About His Surprising Height</a><br><br><a data-lasso-id="87146" href="https://www.gossipcop.com/elton-john-never-sing-again-illness/?utm_source=ref_app_link" target="_blank" rel="noopener">Elton John May Never Sing Again Due To Illness?</a><br><br><a data-lasso-id="87147" href="https://www.gossipcop.com/one-of-dababys-entourage-arrested-for-attempted-murder-see-the-bizarre-mug-shot/192367/?utm_source=ref_app_link" target="_blank" rel="noopener">One Of DaBaby’s Entourage Arrested For Attempted Murder, See The Bizarre Mug Shot</a><br><br><a data-lasso-id="87148" href="https://www.gossipcop.com/elton-john-months-live-tabloid-claim/?utm_source=ref_app_link" target="_blank" rel="noopener">Tabloid Claims Elton John Has Months To Live</a></p>
</div></div><footer class="entry-footer"></footer></article><div class="after-entry widget-area"><div class='post-tag-cloud'><ul><li><a href="https://www.gossipcop.com/t/elton-john/" rel="tag">Elton John</a></li></ul></div> <div class="outbrain-widget" data-config="{&quot;title&quot;:&quot;AR_1 &amp; inf AR_2&quot;,&quot;widget_id&quot;:&quot;AR_1&quot;,&quot;infinite&quot;:1,&quot;infinite_widget_id&quot;:&quot;AR_2&quot;,&quot;display_desktop&quot;:1,&quot;display_tablet&quot;:1,&quot;display_mobile&quot;:1,&quot;disable_on_lmi&quot;:&quot;15000&quot;,&quot;amp_widget_id&quot;:&quot;&quot;,&quot;amp_width&quot;:100,&quot;amp_height&quot;:100,&quot;amp_layout&quot;:&quot;responsive&quot;,&quot;inject_after&quot;:&quot;&quot;,&quot;inject_offset&quot;:3,&quot;inject_not_adjacent&quot;:&quot;img, figure, blockquote, h2&quot;,&quot;inject_not_adjacent_ad&quot;:1,&quot;inject_not_adjacent_blank&quot;:1,&quot;display_amp&quot;:0,&quot;url&quot;:&quot;https:\/\/www.gossipcop.com\/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms\/2567137\/&quot;}"></div>
<section id="text-4" class="widget widget_text"><div class="widget-wrap"> <div class="textwidget"><script defer src="https://embed.secondstreetapp.com/Scripts/dist/optin.js" data-ss-embed="optin" data-design-id="2042795"></script>
</div>
</div></section>
</div><style type="text/css">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</style><div id="ajax-load-more" class="ajax-load-more-wrap infinite classic" data-alm-id="" data-canonical-url="https://www.gossipcop.com/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms/2567137/" data-slug="elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms" data-post-id="2567137" data-localized="ajax_load_more_vars"><div aria-live="polite" aria-atomic="true" class="alm-listing alm-ajax" data-container-type="div" data-loading-style="infinite classic" data-repeater="default" data-post-type="post,affiliate" data-meta-key="is_published_search_list" data-meta-value="1" data-post-in="203455,201305,199394,176848" data-post-not-in="2567137" data-vars="page_type:post" data-order="DESC" data-orderby="post__in" data-offset="0" data-posts-per-page="1" data-scroll="true" data-scroll-distance="-50%" data-max-pages="0" data-pause-override="true" data-pause="true" data-button-label="Load More"></div><div class="alm-btn-wrap" style="visibility: hidden;"><button class="alm-load-more-btn more " rel="next" type="button">Load More</button></div></div></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="gossipcop-post-2" class="widget gossipcop-featured-widget"><div class="widget-wrap"><article class="post-2566566 post type-post status-publish format-standard has-post-thumbnail category-lifestyle entry" aria-label="Gwyneth Paltrow Is Obsessed With These Affordable Beauty Products – And You Will Be, Too"> <div class="gc-featured-post">
<div class="gc-featured-content item-0">
<span class="story-cover-image"><a href="https://www.gossipcop.com/gwyneth-paltrow-favorite-affordable-beauty-products/2566566/" title="Gwyneth Paltrow Is Obsessed With These Affordable Beauty Products – And You Will Be, Too" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/07/Gossip-Cop-Cover-Image-7-400x400.jpg" class="entry-image attachment-post" alt="Image of Gwyneth Paltrow and her favorite beauty products." loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/Gossip-Cop-Cover-Image-7-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/07/Gossip-Cop-Cover-Image-7-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Lifestyle</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/gwyneth-paltrow-favorite-affordable-beauty-products/2566566/">Gwyneth Paltrow Is Obsessed With These Affordable Beauty Products – And You Will Be, Too</a></h2> </header>
</div>
</div>
</article><article class="post-2567120 post type-post status-publish format-standard has-post-thumbnail category-celebrities entry" aria-label="Tracee Ellis Ross Sparks Health Concerns As Fans Note Similarities In Instagram Videos"> <div class="gc-featured-post">
<div class="gc-featured-content item-1">
<span class="story-cover-image"><a href="https://www.gossipcop.com/tracee-ellis-ross-sparks-health-concerns-as-fans-note-similarities-in-instagram-videos/2567120/" title="Tracee Ellis Ross Sparks Health Concerns As Fans Note Similarities In Instagram Videos" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/07/shutterstock_767214886-1-400x400.jpg" class="entry-image attachment-post" alt="(a katz/Shutterstock.com) Tracee Ellis Ross wearing red dress" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/shutterstock_767214886-1-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/07/shutterstock_767214886-1-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Celebrities</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/tracee-ellis-ross-sparks-health-concerns-as-fans-note-similarities-in-instagram-videos/2567120/">Tracee Ellis Ross Sparks Health Concerns As Fans Note Similarities In Instagram Videos</a></h2> </header>
</div>
</div>
</article><article class="post-2567107 post type-post status-publish format-standard has-post-thumbnail category-news entry" aria-label="Lindsie Chrisley Announces Divorce Amidst Legal Woes, What Estranged Dad Todd Has To Say"> <div class="gc-featured-post">
<div class="gc-featured-content item-2">
<span class="story-cover-image"><a href="https://www.gossipcop.com/lindsie-chrisley-announces-divorce-amidst-legal-woes-what-estranged-dad-todd-has-to-say/2567107/" title="Lindsie Chrisley Announces Divorce Amidst Legal Woes, What Estranged Dad Todd Has To Say" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/07/lindsie-chrisley-divorce-400x400.jpg" class="entry-image attachment-post" alt="Lindsie Chrisley poses before a green backround in a red dress" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/lindsie-chrisley-divorce-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/07/lindsie-chrisley-divorce-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">News</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/lindsie-chrisley-announces-divorce-amidst-legal-woes-what-estranged-dad-todd-has-to-say/2567107/">Lindsie Chrisley Announces Divorce Amidst Legal Woes, What Estranged Dad Todd Has To Say</a></h2> </header>
</div>
</div>
</article><article class="post-2566431 post type-post status-publish format-standard has-post-thumbnail category-celebrities tag-corey-gamble tag-kris-jenner tag-verified-content entry" aria-label="Kris Jenner Refused To Give ‘Full-Time Lackey’ Corey Gamble A Raise ‘Countless Times’ Despite Her ‘$170 Million’ Net Worth?"> <div class="gc-featured-post">
<div class="gc-featured-content item-3">
<span class="story-cover-image"><a href="https://www.gossipcop.com/kris-jenner-refused-to-give-full-time-lackey-corey-gamble-a-raise-countless-times-despite-her-170-million-net-worth/2566431/" title="Kris Jenner Refused To Give ‘Full-Time Lackey’ Corey Gamble A Raise ‘Countless Times’ Despite Her ‘$170 Million’ Net Worth?" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1180491898-400x400.jpg" class="entry-image attachment-post" alt="Kris Jenner in a black blouse and jacket with Corey Gamble in a charcoal suit" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1180491898-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1180491898-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Celebrities</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/kris-jenner-refused-to-give-full-time-lackey-corey-gamble-a-raise-countless-times-despite-her-170-million-net-worth/2566431/">Kris Jenner Refused To Give ‘Full-Time Lackey’ Corey Gamble A Raise ‘Countless Times’ Despite Her ‘$170 Million’ Net Worth?</a></h2> </header>
</div>
</div>
</article><article class="post-2566435 post type-post status-publish format-standard has-post-thumbnail category-celebrities tag-blake-shelton tag-miranda-lambert tag-verified-content entry" aria-label="Miranda Lambert Wants ‘Revenge’ After Blake Shelton ‘Deliberately Sabotaged’ Her Comeback Tour?"> <div class="gc-featured-post">
<div class="gc-featured-content item-4">
<span class="story-cover-image"><a href="https://www.gossipcop.com/miranda-lambert-wants-revenge-after-blake-shelton-deliberately-sabotaged-her-comeback-tour/2566435/" title="Miranda Lambert Wants ‘Revenge’ After Blake Shelton ‘Deliberately Sabotaged’ Her Comeback Tour?" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-463031434-400x400.jpg" class="entry-image attachment-post" alt="Blake Shelton in a charcoal suit with Miranda Lambert in a black dress" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-463031434-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-463031434-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Celebrities</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/miranda-lambert-wants-revenge-after-blake-shelton-deliberately-sabotaged-her-comeback-tour/2566435/">Miranda Lambert Wants ‘Revenge’ After Blake Shelton ‘Deliberately Sabotaged’ Her Comeback Tour?</a></h2> </header>
</div>
</div>
</article></div></section>
<div class="outbrain-widget" data-config="{&quot;title&quot;:&quot;SB_1&quot;,&quot;widget_id&quot;:&quot;SB_1&quot;,&quot;infinite_widget_id&quot;:&quot;&quot;,&quot;display_desktop&quot;:1,&quot;disable_on_lmi&quot;:&quot;15000&quot;,&quot;amp_widget_id&quot;:&quot;&quot;,&quot;amp_width&quot;:100,&quot;amp_height&quot;:100,&quot;amp_layout&quot;:&quot;responsive&quot;,&quot;inject_after&quot;:&quot;&quot;,&quot;inject_offset&quot;:3,&quot;inject_not_adjacent&quot;:&quot;img, figure, blockquote, h2&quot;,&quot;inject_not_adjacent_ad&quot;:1,&quot;inject_not_adjacent_blank&quot;:1,&quot;infinite&quot;:0,&quot;display_tablet&quot;:0,&quot;display_mobile&quot;:0,&quot;display_amp&quot;:0,&quot;url&quot;:&quot;https:\/\/www.gossipcop.com\/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms\/2567137\/&quot;}"></div>
<section id="gossipcop-post-3" class="widget gossipcop-featured-widget"><div class="widget-wrap"><article class="post-2566348 post type-post status-publish format-standard has-post-thumbnail category-lifestyle entry" aria-label="Woman That Was Fat Shamed By Doctor, Later Diagnosed With Cancer Is Sadly All Too Relatable"> <div class="gc-featured-post">
<div class="gc-featured-content item-0">
<span class="story-cover-image"><a href="https://www.gossipcop.com/woman-fat-shamed-by-doctor-later-diagnosed-with-cancer/2566348/" title="Woman That Was Fat Shamed By Doctor, Later Diagnosed With Cancer Is Sadly All Too Relatable" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/07/shutterstock_558136654-scaled-e1627077502582-400x400.jpg" class="entry-image attachment-post" alt="Doctor crossing their arms, holding stethoscope." loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/shutterstock_558136654-scaled-e1627077502582-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/07/shutterstock_558136654-scaled-e1627077502582-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Lifestyle</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/woman-fat-shamed-by-doctor-later-diagnosed-with-cancer/2566348/">Woman That Was Fat Shamed By Doctor, Later Diagnosed With Cancer Is Sadly All Too Relatable</a></h2> </header>
</div>
</div>
</article><article class="post-2566643 post type-post status-publish format-standard has-post-thumbnail category-royals tag-prince-harry tag-verified-content entry" aria-label="Royal Family ‘Reeling’ After Prince Harry’s ‘Explosive’ $27M Biography ‘Leaked’?"> <div class="gc-featured-post">
<div class="gc-featured-content item-1">
<span class="story-cover-image"><a href="https://www.gossipcop.com/royal-family-reeling-after-prince-harrys-explosive-27m-biography-leaked/2566643/" title="Royal Family ‘Reeling’ After Prince Harry’s ‘Explosive’ $27M Biography ‘Leaked’?" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1233755651-400x400.jpg" class="entry-image attachment-post" alt="Prince Harry smiling in a blue coat outside" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1233755651-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1233755651-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Royals</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/royal-family-reeling-after-prince-harrys-explosive-27m-biography-leaked/2566643/">Royal Family ‘Reeling’ After Prince Harry’s ‘Explosive’ $27M Biography ‘Leaked’?</a></h2> </header>
</div>
</div>
</article><article class="post-2566318 post type-post status-publish format-standard has-post-thumbnail category-celebrities entry" aria-label="Who Is Dev Patel&#8217;s Girlfriend? The Truth About His Relationship With Tilda Cobham-Hervey"> <div class="gc-featured-post">
<div class="gc-featured-content item-2">
<span class="story-cover-image"><a href="https://www.gossipcop.com/dev-patel-girlfriend-tilda-cobham-hervey/2566318/" title="Who Is Dev Patel&#8217;s Girlfriend? The Truth About His Relationship With Tilda Cobham-Hervey" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/07/DevPatel_Tilda-scaled-e1627405604356-400x400.jpg" class="entry-image attachment-post" alt="Actor Dev Patel and his girlfriend actress Tilda Cobham-Hervey" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/DevPatel_Tilda-scaled-e1627405604356-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/07/DevPatel_Tilda-scaled-e1627405604356-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Celebrities</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/dev-patel-girlfriend-tilda-cobham-hervey/2566318/">Who Is Dev Patel&#8217;s Girlfriend? The Truth About His Relationship With Tilda Cobham-Hervey</a></h2> </header>
</div>
</div>
</article><article class="post-2566572 post type-post status-publish format-standard has-post-thumbnail category-celebrities tag-angelina-jolie entry" aria-label="Is Angelina Jolie Still The &#8216;Neighbor From Hell&#8217;?"> <div class="gc-featured-post">
<div class="gc-featured-content item-3">
<span class="story-cover-image"><a href="https://www.gossipcop.com/is-angelina-jolie-still-the-neighbor-from-hell/2566572/" title="Is Angelina Jolie Still The &#8216;Neighbor From Hell&#8217;?" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1179644759-400x400.jpg" class="entry-image attachment-post" alt="Angelina Jolie in a shiny black dress" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1179644759-400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/07/GettyImages-1179644759-150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Celebrities</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/is-angelina-jolie-still-the-neighbor-from-hell/2566572/">Is Angelina Jolie Still The &#8216;Neighbor From Hell&#8217;?</a></h2> </header>
 </div>
</div>
</article><article class="post-2566992 post type-post status-publish format-standard has-post-thumbnail category-celebrities category-news tag-ashton-kutcher tag-mila-kunis entry" aria-label="Mila Kunis, Ashton Kutcher Have Lower Standards For Personal Hygiene, Here’s The Shocking Reason Why"> <div class="gc-featured-post">
<div class="gc-featured-content item-4">
<span class="story-cover-image"><a href="https://www.gossipcop.com/mila-kunis-ashton-kutcher-have-lower-standards-for-personal-hygiene-heres-the-shocking-reason-why/2566992/" title="Mila Kunis, Ashton Kutcher Have Lower Standards For Personal Hygiene, Here’s The Shocking Reason Why" class="aligncenter"><img width="400" height="400" src="https://upload.gossipcop.com/gc/uploads/2021/07/mila-kunis-ashton-kutcher-hygiene--400x400.jpg" class="entry-image attachment-post" alt="" loading="lazy" srcset="https://upload.gossipcop.com/gc/uploads/2021/07/mila-kunis-ashton-kutcher-hygiene--400x400.jpg 400w, https://upload.gossipcop.com/gc/uploads/2021/07/mila-kunis-ashton-kutcher-hygiene--150x150.jpg 150w" sizes="(max-width: 400px) 100vw, 400px" /></a></span>
<p class="entry-meta"><span class="entry-categories">Celebrities</span></p>
<header class="entry-header">
<h2 class="entry-title"><a href="https://www.gossipcop.com/mila-kunis-ashton-kutcher-have-lower-standards-for-personal-hygiene-heres-the-shocking-reason-why/2566992/">Mila Kunis, Ashton Kutcher Have Lower Standards For Personal Hygiene, Here’s The Shocking Reason Why</a></h2> </header>
</div>
</div>
</article></div></section>
</aside></div></div><footer class="site-footer"><div class="wrap"><a href="https://gossipcop.com"> <p class=footer-image></p></a><p></p><nav class="nav-secondary" aria-label="Secondary"><div class="wrap"><ul id="menu-footer-nav" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-159244" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-159244"><a href="/"><span>© 2021 Gossip Cop Media</span></a></li>
<li id="menu-item-159242" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159242"><a href="https://www.gossipcop.com/about/"><span>About Us</span></a></li>
<li id="menu-item-159238" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159238"><a href="https://www.gossipcop.com/newsletter/"><span>Newsletter</span></a></li>
<li id="menu-item-159241" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159241"><a href="https://www.gossipcop.com/privacy/"><span>Privacy</span></a></li>
<li id="menu-item-159240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159240"><a href="https://www.gossipcop.com/terms/"><span>User Agreement</span></a></li>
<li id="menu-item-159239" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159239"><a href="https://www.gossipcop.com/contact/"><span>Contact</span></a></li>
<li id="menu-item-159243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-159243"><a href="/feed/"><span>RSS</span></a></li>
</ul></div></nav></div></footer> <div class="corpfooter">
<div class="contents">
<ul>
<li class="copyright"><span>&copy;Copyright 2021</span></li>
<li class="quilltlogo">
<a href="https://www.quillt.com" target="_blank">
<img class="logo" loading="lazy" src=" https://www.gossipcop.com/wp-content/plugins/quillt/assets/corpfooter/logo-quillt-black.png " alt="Quillt Corporate Logo" width="100px">
</a>
</li>
<li class="privacy">
<span>
For details on Quillt's privacy and cookie policies, please visit our
<a href="https://www.quillt.com/privacy-policy/" target="_blank">privacy policy</a>
page.
</span>
</li>
</ul>
<div id="choice-footer-msg" class="consent-ccpa-notice"></div>
</div>
</div>
</div> <div id="fb-root"></div>
<script>
    (function() {
        var enabled_integrations = {
            'params': {},
            'session': {},
            'scroll': {},
            'rev_block': {},
            'performance': {}
        };
        // Enable the prebid integration 1% of the time
        if ((Math.random() * 100) < 1) {
            enabled_integrations.prebid = {};
        }


        var pageparams = {"env":"production","content_id":2567137,"site":"GC","page":"single","lmi":5,"s":"1a999f854a","rid":"c17d8cf1-c061-4cd0-bca2-d0c4fca602de","jigsaw_hash":"17766","full":"https:\/\/www.gossipcop.com\/elton-john-puts-rapper-on-blast-has-twitter-users-up-in-arms\/2567137\/"};

        // Grab Clean Creative from setup_clean_creative
        pageparams.clcr = window._cc_included ? 1 : 0;

        (window._bsq = window._bsq || []).push(
            ['configure', {
                lifetime_parameters: {},
                session_parameters: {},
                page_parameters: pageparams,
                AWS_identity_pool_id: '3f9d4436-de0e-4ab4-a1a9-bb1fb8842252',
                AWS_region: 'us-east-1',
                stream: 'firehose-batsignal-GC',
                integrations: enabled_integrations
            }]
        );

        window._bsq.push(['send_event', 'page_view', {}]);

        let seen_ids = [];
        window.almUrlUpdate = function(permalink, type){
            let match = permalink.match(/\/(\d+)\/?(\?.*)?(#.*)?$/);
            if (match && match.length >= 2 && match[1]) {
                let pparams = {
                    'content_id': match[1],
                    'full': permalink,
                };
                window._bsq.push(['set_page_parameters', pparams, false, permalink]);
                if (seen_ids.indexOf(match[1]) < 0) {
                    window._bsq.push(['send_event', 'page_view', {}]);
                    seen_ids.push(match[1]);
                }
            }
        };
    })();
</script><script src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/filter_links_new_tab.js?ver=d2227f300529686f76f8' id='quillt-filter-links-new-tab-js'></script>
<script src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/ads-prebid.js?ver=f6e2186486eb52f45ccb' id='ads-prebid-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/batsignal/aws-sdk.2.190.0.min.js?ver=4f1a5556647321da9441' id='aws-sdk-js'></script>
<script id='batsignal-js-extra'>
var wp_domain = {"quillt":"wordpress"};
</script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/batsignal/batsignal_js.min.js?ver=a13fdf9b90273cfc718a' id='batsignal-js'></script>
<script id='ajax-load-more-js-extra'>
var alm_localize = {"ajaxurl":"https:\/\/www.gossipcop.com\/wp\/wp-admin\/admin-ajax.php","alm_nonce":"ee92e74742","rest_api":"https:\/\/www.gossipcop.com\/wp-json\/","rest_nonce":"be4efacfd9","pluginurl":"https:\/\/www.gossipcop.com\/wp-content\/plugins\/ajax-load-more","speed":"200","ga_debug":"false","results_text":"Viewing {post_count} of {total_posts} results.","no_results_text":"No results found.","alm_debug":"","a11y_focus":"1","site_title":"Gossip Cop","site_tagline":"Honest Celebrity News & Gossip"};
var ajax_load_more_vars = {"id":"ajax-load-more"};
</script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/ajax-load-more/core/dist/js/ajax-load-more.min.js?ver=5.5.0' id='ajax-load-more-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/inf_scroll.js?ver=3606da7efd9131093594' id='inf_scroll-js'></script>
<script defer src='https://www.gossipcop.com/wp/wp-includes/js/hoverIntent.min.js?ver=1.8.1' id='hoverIntent-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10' id='superfish-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.3.3' id='superfish-args-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.3.3' id='skip-links-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/social_login/general.js?ver=7.13.21' id='the_champ_ss_general_scripts-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/social_login/common.js?ver=7.13.21' id='the_champ_sl_common-js'></script>
<script id='thickbox-js-extra'>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.gossipcop.com\/wp\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script defer src='https://www.gossipcop.com/wp/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/facebook/sdk.js?ver=7.13.21' id='the_champ_fb_sdk-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/facebook/commenting.js?ver=7.13.21' id='the_champ_fb_commenting-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/super-socializer/js/front/sharing/sharing.js?ver=7.13.21' id='the_champ_share_counts-js'></script>
<script defer src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/outbrain.js?ver=437ed88dcfcaef96260a' id='quillt-outbrain-widget-js'></script>
<script id='gossipcop-responsive-menu-js-extra'>
var genesis_responsive_menu = {"mainMenu":"","menuIconClass":"dashicons-before dashicons-menu","subMenu":"Submenu","subMenuIconClass":"dashicons-before dashicons-arrow-down-alt2","menuClasses":{"others":[".nav-primary"]}};
</script>
<script defer src='https://www.gossipcop.com/wp-content/themes/genesis/lib/js/menu/responsive-menus.min.js?ver=1.1.3' id='gossipcop-responsive-menu-js'></script>
<script id='quillt_google_analytics-js-extra'>
var quillt_ga_settings = {"domain":"www.gossipcop.com"};
</script>
<script src='https://www.gossipcop.com/wp-content/plugins/quillt/assets/google_analytics.js?ver=0dcdf4496ba7f66a8715' id='quillt_google_analytics-js'></script>
<script src='https://www.gossipcop.com/wp-content/plugins/aawp/assets/dist/js/main.js?ver=3.15.2' id='aawp-js'></script>
<script defer src='https://www.gossipcop.com/wp/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
</body></html>
